Object not found message for new install

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Object not found message for new install

Postby rooks » 16. August 2011 11:06

Hello,

Yesterday I downloaded and installed XAMPP Windows 1.7.4 from the Installer option onto my machine running Windows 7 Ultimate (although phpinfo says 'Windows NT ...6.1 build 7601 ((null) Service Pack 1) i586).
I then created a couple of small php files from Dreamweaver and placed these directly in the htdocs folder. However when I try to view the file in my browser (http://localhost/myfiles.php) I am getting a 404 error.

I have started Apache & MySql running and can can navigate successfully to the XAMPP Control Panel (http://localhost/xampp/index.php) & a few other files that came with the install, but not any of my own.

I have tried connecting with my Firewall turned off, and have run the port-check.exe file : Port 80 & Port 443 are boths showing as Apache Services, Status = System. (sorry I'm not sure if this is good or bad - I just thought this info might be relevamt from another thread)

I have checked the error.log file in C:\xampp\apache\logs but the file is empty. I did clear it down with the intention of starting my analysis with a 'blank slate' but despite the fact that I have had several 404 errors since, there is still nothing in there.

Below are my phpinfo settings, not sure if anthing here is relevant.

Any help would be greatly appreciated.

Thanks a lot



System Windows NT ****DEV04 6.1 build 7601 ((null) Service Pack 1) i586
Build Date Nov 20 2009 17:20:57
Compiler MSVC6 (Visual C++ 6.0)
Architecture x86
Configure Command cscript /nologo configure.js "--enable-snapshot-build"
Server API Apache 2.0 Handler
Virtual Directory Support enabled
Configuration File (php.ini) Path no value
Loaded Configuration File C:\DEVELOPMENT SERVER\xampp\php\php.ini
Scan this dir for additional .ini files (none)
Additional .ini files parsed (none)
PHP API 20090626
PHP Extension 20090626
Zend Extension 220090626
Zend Extension Build API220090626,TS,VC6
PHP Extension Build API20090626,TS,VC6
Debug Build no
Thread Safety enabled
Zend Memory Manager enabled
Zend Multibyte Support disabled
IPv6 Support enabled
Registered PHP Streams https, ftps, php, file, glob, data, http, ftp, compress.zlib, compress.bzip2, phar, zip
Registered Stream Socket Transports tcp, udp, ssl, sslv3, sslv2, tls
Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, zlib.*, bzip2.*
rooks
 
Posts: 3
Joined: 16. August 2011 10:25

Re: Object not found message for new install

Postby Nobbie » 16. August 2011 12:44

>Loaded Configuration File C:\DEVELOPMENT SERVER\xampp\php\php.ini

What is that?? Where did you install xampp?
Nobbie
 
Posts: 8760
Joined: 09. March 2008 13:04

Re: Object not found message for new install

Postby JonB » 16. August 2011 18:19

\DEVELOPMENT SERVER

-----------------------------^-------------------------
likely source of your issue

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Object not found message for new install

Postby rooks » 16. August 2011 18:47

thanks for the replies. I just ran the installer file from my desktop (on a pc at work) & let it do it's stuff. Is there a way around this? I mean I could run the installer again but since I didn't specify any settings won't the same thing happen again?

Thanks again
rooks
 
Posts: 3
Joined: 16. August 2011 10:25

Re: Object not found message for new install

Postby JonB » 16. August 2011 21:22

I mean I could run the installer again but since I didn't specify any settings won't the same thing happen again?


NOT if you don't try to put it (XAMPP) in a folder that has a space in it... :shock:

you can also DL the ZIP file and skip the installer. Just unzip it into the folder you like (no spaces), and run setup_xampp.bat

the 'best' place for XAMPP, is in the root of an internal drive.

BUT folders with spaces and certain special characters are prescriptions for disaster. the reason is simple - most of the parts of XAMPP originated on Unix, and it does not like spaces in folder names.

Good Luck
8)

yrpfs
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Object not found message for new install

Postby rooks » 17. August 2011 09:02

thanks for all your help. Just checked my c drive this morning and it would unbeknownst to me it would appear that the guy who worked here previosuly installed XAMPP into that Development Folder . I will remove that folder & try my install again. Cheers !
rooks
 
Posts: 3
Joined: 16. August 2011 10:25


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests