PHP not loading any configs

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP not loading any configs

Postby NILPhotography » 11. August 2011 14:51

HI all, I've been using Xampp for about 6 months and ever since I installed it, it has always given out a fatal error every time there is a curl_int() in a page, so I got bored of this and googled the issue answer edit the ini file removing extension =curl.dll
I did that restarted apache but nothing changed still fatal error I looked at the control panel and php is not loading any configuration files.

Can anyone suggest how I make it load my php.ini which it currently isn't?

Many thanks, it will save my webserver bandwidth no end as thats my only option to upload it there to test which somewhat defeats the object of xampp.
NILPhotography
 
Posts: 1
Joined: 11. August 2011 14:47

Re: PHP not loading any configs

Postby Sharley » 12. August 2011 04:22

First a good idea might be to download the latest version3 Control Panel and extract the xampp_control3.exe to the same location as the other one usually C:\xampp in a default installation - download link in my signature and the topic is here:
viewtopic.php?f=16&t=46743

Save the zip file for future use, also do not extract the src folder or you will be asked to overwrite the existing src folder in C:\xampp which contains other source code files that may be required at some time perhaps - these source code file are not required for normal use, only for those familiar with editing and compiling source code would require them.

Simply double click on the exe file to use and create a shortcut somewhere handy for easy use.
Make sure the original control panel is exited before try to run the new one - you will find it far superior with many nice features.



How have ascertained that there is no php.ini file being loaded?

Now start Apache and MySQL, make sure they are running and then go to http://localhost/xampp/phpinfo.php and look for this item
Code: Select all
Loaded Configuration File
It should say C:\xampp\php\php.ini file in a default installation.

Let us know back what file it say is loaded.

Which php.ini file did you delete the extension in?
There is no need to delete the extension and it should not be deleted.

This extension in a default installation is already commented out (disabled) and looks like this
Code: Select all
;extension=php_curl.dll
To get rid of the annoying error message do not delete this extension but simply remove the comment out character so it looks like this
Code: Select all
extension=php_curl.dll
As normal, save the file and restart Apache to have your edits read.

You should then not have any issues with curl when there is a curl_int() in a page.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests