phpMyAdmin will not start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpMyAdmin will not start

Postby viceguy » 08. August 2011 15:33

I have installed Xampp today and only changed the mysql root password. I have also edited the config.inc.php file with the new root password.

Still i keep getting this error:

Error

MySQL said:
#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

Connection for controluser as defined in your configuration failed.


Can someone pease help this newbee ???
viceguy
 
Posts: 6
Joined: 07. August 2011 15:39

Re: phpMyAdmin will not start

Postby viceguy » 08. August 2011 18:42

I made some screen caputers that might help

Image
viceguy
 
Posts: 6
Joined: 07. August 2011 15:39

Re: phpMyAdmin will not start

Postby JonB » 08. August 2011 20:39

What specific version of XAMPP did you install?? :?:

What is in the tail (last part) of \xampp\mysql\data\mysql,err (its a text file, open with notepad will be OK)


Inquiring minds need to know...

:roll:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: phpMyAdmin will not start

Postby viceguy » 08. August 2011 20:53

i'm using V 1.7.4

This is my system details btw:

CPU: Intel(R) Pentium(R) Dual CPU E2200 @ 2.20GHz (2218.18 MHz)
Memory: 2048 MB
OS Version: Microsoft Windows 7 32-bit Service Pack 1 (Build 7601)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GT 220/PCI/SSE2
Windows Graphics Driver Version: 8.17.0012.7533
OpenGL Version: 3.3.0

This is the tail of the mysql_error.log

Version: '5.5.8' socket: '' port: 3306 MySQL Community Server (GPL)
110808 21:05:38 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
110808 21:05:38 InnoDB: Initializing buffer pool, size = 16.0M
110808 21:05:38 InnoDB: Completed initialization of buffer pool
110808 21:05:38 InnoDB: highest supported file format is Barracuda.
110808 21:05:39 InnoDB: 1.1.4 started; log sequence number 48974289
110808 21:05:39 [Note] Event Scheduler: Loaded 0 events
110808 21:05:39 [Note] mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.8' socket: '' port: 3306 MySQL Community Server (GPL)
viceguy
 
Posts: 6
Joined: 07. August 2011 15:39

Re: phpMyAdmin will not start

Postby JonB » 08. August 2011 21:10

Ok

See if you can connect/use your database with the XAMPP page

http://localhost/xampp/

see if the CD collection works - IF SO - no matter what other things may be reported by the Status Page, MySQL is running.OK.
(don't use Phone Book - its built around sqlite)

IF it (MySQL) is running, THEN the problem is with the changes you made to config.inc.php

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: phpMyAdmin will not start

Postby viceguy » 08. August 2011 21:25

Bad news Jon, i was able to use http://localhost/xampp/
but the CD collection gave me this error:

Warning: mysql_connect() [function.mysql-connect]: [2002] A connection attempt failed because the connected party did not (trying to connect via tcp://localhost:3306) in C:\xampp\htdocs\xampp\cds.php on line 64

Warning: mysql_connect() [function.mysql-connect]: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. in C:\xampp\htdocs\xampp\cds.php on line 64


Could not connect to database!
Is MySQL running or did you change the password?

I was able to access it yesterday right after the installation of xampp.... before i started to fart around with ini and settings files :(
I have however never been able to see mysql server to be active in http://localhost/xampp/status.php

As a last desperate option i uninstalled Xampp from my system ,did a restart and reinstalled it, but now the bugger give me the same error when trying to open the CD collection.
viceguy
 
Posts: 6
Joined: 07. August 2011 15:39

Re: phpMyAdmin will not start

Postby JonB » 09. August 2011 00:19

I'm going to take a WAG (Wild-Ass-Guees)

I think some firewall software is blocking the port. I remember another case like this on this Forum. (I'll have to look for it, the error expressed itself with a bit different symptom)

MySQL is probably running OK (that's why 'no errors') and also the fact that the XAMPP CP says its working

BUT the port (3306) is unavailable because it is blocked by an external agent.

If you have a firewall enabled, unplug for a second and disable it, then test. :shock:

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: phpMyAdmin will not start

Postby viceguy » 09. August 2011 09:27

yes, that did work. I disabled Norman firewall and then i could both open the CD collection and also on the status page see mysql running. So i guess my neqst step will be to figure out how to set the firewall to work as it should :shock:

You do not happen to know Norman Security Suite and how i go about opening for mysql?
viceguy
 
Posts: 6
Joined: 07. August 2011 15:39

Re: phpMyAdmin will not start

Postby JonB » 09. August 2011 13:21

I disabled Norman firewall


Maybe 'Norton'??? :)

Anyway - I'm glad we identified the problem. You can probably find help with that 'allow MySQL issue' in a Norton forum. I don't know why it would have blocked MySQL, I have not had that issue before with Norton.

Good luck with XAMPP
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: phpMyAdmin will not start

Postby viceguy » 09. August 2011 14:24

viceguy
 
Posts: 6
Joined: 07. August 2011 15:39

Re: phpMyAdmin will not start

Postby JonB » 09. August 2011 14:55

Well, yet another AVAM vendor

LOL - looking at their management team, they have the right name :D

thanks for the info and good luck

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests

cron