Broken images (XP SP3) 1.7.4 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Broken images (XP SP3) 1.7.4 [SOLVED]

Postby Geri » 02. August 2011 14:15

All image that is bigger than around ~110 kbyte is served broken.

Its just broken with xampp, even if i try to view it from localhost.
Of course, i checked it, and the image stored correctly on the server. Just xampp serves it brokenly somehow.

I searched in http.conf and php.ini, but i not find the solution. What setting should i modify to fix this issue?
Geri
 
Posts: 20
Joined: 02. August 2011 14:10
Operating System: linux

Re: Broken images

Postby JonB » 02. August 2011 15:28

A. what kind of a file is it? (extension)

B. how/what is serving the image - a link in an HTML page??? Could be the image tag contains invalid dimension information (for instance).

C. what is the URL you are suing to serve the image??

its very unlikely the problem is really with XAMMP, much more likely the problem is browser or URL related. (or a misunderstanding of the format/browser issues)

the SURE way to tell what is going on is to enter the files URL in the browser.
i.e.

http://localhost/images/myimagefile.jpg

(or whatever)

Good Luck
8)



ydf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Broken images

Postby Geri » 02. August 2011 15:32

thank you for your answer.

for example:
*link removed*

its pure damaged.
(the file is not broken itself, it display on my hdd correctly)

(maybee also other kind of large file types also damaged, but i has images only above this file size)
Last edited by Geri on 02. August 2011 19:06, edited 1 time in total.
Geri
 
Posts: 20
Joined: 02. August 2011 14:10
Operating System: linux

Re: Broken images

Postby Geri » 02. August 2011 17:19

i was not able to resolve the problem, now i try wamp, thanks for the help
Geri
 
Posts: 20
Joined: 02. August 2011 14:10
Operating System: linux

Re: Broken images

Postby Geri » 02. August 2011 19:05

Wamp was also broken. So i uninstalled systematically every program from my computer, until i have found out that a very low-quality program, called ,,netlimiter'' was caused this bad behavior. More precisely, netlimiter's kernel mode driver is broken, and somehow closed down apache's outgoing data transfers after 128 kbyte. Uninstalling this bad software caused xampp to work again.
Geri
 
Posts: 20
Joined: 02. August 2011 14:10
Operating System: linux

Re: Broken images

Postby JonB » 02. August 2011 21:02

Well, I'm glad you found it. I certainly never would have guessed such a thing.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 25 guests