Hosting basic ImpressPages Website Remote Access Troubles

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Hosting basic ImpressPages Website Remote Access Troubles

Postby DJ_Ben_DJB » 26. July 2011 23:50

Hi.

I'm having trouble trying to host a simple ImpressPage Website for demo purposes.
I've set the site up using xampp and have installed the ImpressPages (similar to Wordpress) and is working perfectly on my local machine.

However. When i try to access the machine using its IP address from another machine on the same network it shows the content but all the Images, Icons, Links etc are not showing (also CSS is not loading).

I've open the source on the remote machines web browser and it seems to be pointing to 127.0.0.1 at the start of each file location to be loaded, which is incorrect because that means its looking for the folder inside itself??

I've spent mean hours trying to look up a soulution but just can't find it. I'm new to xampp and all its components but i think i have the basics to get it to work.

I Have a feeling its something to do with the PHP. I've pulled up the PHP Info and it seem to be showing its server address as 127.0.0.1.
I've had a look at most conf files trying to change the 127.0.0.1 address to its static address which in my case is 192.168.100.100. also had a look at host file but still no fix.

I was woundering if some of you kind people could shed some light on the situation and help me fix the problem.

Thanks Very Much Guys

Regards
Ben
DJ_Ben_DJB
 
Posts: 3
Joined: 26. July 2011 23:33

Re: Hosting basic ImpressPages Website Remote Access Trouble

Postby DJ_Ben_DJB » 28. July 2011 19:28

Bump*
DJ_Ben_DJB
 
Posts: 3
Joined: 26. July 2011 23:33

Re: Hosting basic ImpressPages Website Remote Access Trouble

Postby JonB » 28. July 2011 20:33

does your 'xampp' page display correctly on the remote machine???

http://xxx.xxx.xxx.xxx/xampp/

IF SO, the problem is with your configuration of your blog/CMS.

I've open the source on the remote machines web browser and it seems to be pointing to 127.0.0.1 at the start of each file location to be loaded, which is incorrect because that means its looking for the folder inside itself??
err, bingo

:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Hosting basic ImpressPages Website Remote Access Trouble

Postby DJ_Ben_DJB » 06. August 2011 21:31

Hi there :)
Yeah I can access the xampp page using the hosts IP address followed by /xampp (http://xxx.xxx.xxx.xxx/xampp) on remote machine and displays correctly but still doesn't work with the Impresspages directory. its not displaying the page correctly, I can see the content i"ve created but just not images, CSS, etc.
Weird!!!!!!

I"ve re-installed it on a seperate machine and still getting the same effect?? The ImpressPagesCMS config files are inbedded into my eyes now and just can't figure it out.
DJ_Ben_DJB
 
Posts: 3
Joined: 26. July 2011 23:33


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 71 guests