Xampp can't start up Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp can't start up Apache

Postby Beauseant » 26. July 2011 16:32

It seems to be a regular problem that people can't get Apache to work with Xampp, because their port is already being used (port 80). The point is that i can't see anything at CMD that shows that the port is already being used. I tried to set the port on another port like 85, and that didn't work. So i tried to set it on 8016, but that didn't work also. When i tried to manually boot Apache at the Xampp folder i started to get the following error: 'Could not bind to 0.0.0.0.:443' is there any way i can fix this? Or is there any like other program that lets me use MYSQL and Apache at the same time? Please respond, i need some answers because i'm new to all of this. :oops:
Beauseant
 
Posts: 3
Joined: 26. July 2011 16:26

Re: Xampp can't start up Apache

Postby Beauseant » 26. July 2011 17:07

So my question is, is there any other program? Or way to fix this? I've reinstalled it 10times today...
Beauseant
 
Posts: 3
Joined: 26. July 2011 16:26

Re: Xampp can't start up Apache

Postby Altrea » 26. July 2011 17:49

Beauseant wrote:It seems to be a regular problem that people can't get Apache to work with Xampp, because their port is already being used (port 80).

No. Because they don't read the error messages.

Beauseant wrote:The point is that i can't see anything at CMD that shows that the port is already being used.

So, what do you type in your command line? wrong port? wrong flag? wrong command? thats all possible, but you don't give any info about that.

Beauseant wrote:I tried to set the port on another port like 85, and that didn't work.

Which is the correct behaviour in your case. You changed the wrong port.

Beauseant wrote:When i tried to manually boot Apache at the Xampp folder i started to get the following error: 'Could not bind to 0.0.0.0.:443' is there any way i can fix this?

Sure. Read this error message very very slowly. The number after the colon is the port number. So, what port is it? correct. Your SSL Port is blocked by another program.

Apache needs two Ports in the defualt configuration. One for HTTP communication and one for HTTPS/SSL communication. The configuration for SSL is in another configuration file.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Xampp can't start up Apache

Postby Beauseant » 26. July 2011 17:57

Thanks for the reply, but port 443 isn't in use. I checked it at cmd, so i don't know what to do, seriously i've tried nearly everything.
Beauseant
 
Posts: 3
Joined: 26. July 2011 16:26

Re: Xampp can't start up Apache

Postby Altrea » 26. July 2011 18:08

I don't want to repeat myself.
Without to know what you type in your command line to chack the port, it is impossible to say if this info is correct.
Apache tells you, that this port is in use.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests