Cant start apache, it does not color green

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cant start apache, it does not color green

Postby garfy » 24. July 2011 10:36

I reinstalled the xampp in same folder

e: xampp

and when i try to run apache, the icon does not color itself green it says busy

localhost gives me blank page

any idea?
garfy
 
Posts: 36
Joined: 14. January 2011 08:32

Re: Cant start apache, it does not color green

Postby smokealone » 24. July 2011 10:43

is normal push on status and you see

httpd stats 0 service 1

your sarver is worked but is a like some flesh bug .. :)
is not show green but work any way
smokealone
 
Posts: 5
Joined: 24. July 2011 08:04

Re: Cant start apache, it does not color green

Postby garfy » 24. July 2011 11:04

it does not work, localhost gives me blank page

after install i got notification that both ports are blocked, 80 and the other one too.

what to do?

I have win 7
garfy
 
Posts: 36
Joined: 14. January 2011 08:32

Re: Cant start apache, it does not color green

Postby smokealone » 24. July 2011 13:47

sorry dud i don't use win7 is a shit ...
open computer management, services and applications ma by you already have server on boar ?

if not open firewall and watch what use port 80
smokealone
 
Posts: 5
Joined: 24. July 2011 08:04

Re: Cant start apache, it does not color green

Postby garfy » 24. July 2011 17:12

win 7 is cool

i cant understand you good, your english is bad

what should i do, i cant start mysql and apache now
garfy
 
Posts: 36
Joined: 14. January 2011 08:32

Re: Cant start apache, it does not color green

Postby garfy » 24. July 2011 18:47

why I cant run this program?

People would assume that most of us use skype and that skype might use the port 80. So why not to move the port of apache and mysql to something random?

This stuff should work out of the box, I am looking for alternative
garfy
 
Posts: 36
Joined: 14. January 2011 08:32

Re: Cant start apache, it does not color green

Postby Altrea » 24. July 2011 19:47

garfy wrote:People would assume that most of us use skype and that skype might use the port 80. So why not to move the port of apache and mysql to something random?


Because these Ports are all default ports.
Port 80 is the default port for HTTP communication
Port 443 is the default port for HTTPS/SSL communication
Port 3306 is the default port for MySQL.

e.g. when you change the port for HTTP to Port 81, you have to add on every request to your HTTP Daemon this port, so that your server knows, that this Request is for him.
http://my.url.com:81/index.php doesn't look really beautiful does it? And all of your webapplication have to handle this port too.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8291
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Cant start apache, it does not color green

Postby garfy » 25. July 2011 02:33

so what is the solution for this problem?

I cant use the program

is it because I installed it before in e: xampp location, but I reformatted the disc C:
garfy
 
Posts: 36
Joined: 14. January 2011 08:32

Re: Cant start apache, it does not color green

Postby Sharley » 25. July 2011 03:18

See if by following exactly the instructions in this post to uninstall and then reinstall using a different method helps your case:
viewtopic.php?p=179699#p179699

Also download and extract the exe file of the new version 3 of the XAMPP Control Panel to the xampp installation folder, then use it instead of the CP included in the release.
Topic here:
viewtopic.php?f=16&t=46743
Download link is in my signature.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Cant start apache, it does not color green

Postby garfy » 01. August 2011 10:45

this program is really hard to manage

I now have to disable skype, everytime I run xampp

I need my skype online all the time for god sake
garfy
 
Posts: 36
Joined: 14. January 2011 08:32

Re: Cant start apache, it does not color green

Postby Sharley » 01. August 2011 12:50

garfy wrote:I now have to disable skype, everytime I run xampp

I need my skype online all the time for god sake
Skype uses ports 80 and 443 by default.

You can alter that behavior by going to:
Tools\Connection options...\Connections

Untick
Use port 80 and 443 as alternative for incoming connections

Now you can have Skype and Apache running at the same time.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests