Can't run Apache with xampplite 1.7.0 on XP SP3

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't run Apache with xampplite 1.7.0 on XP SP3

Postby Alex45 » 01. July 2011 06:18

Hello,

This is my first post on this forum. I spent many hours checking whether I could find a solution on this forum and others but nothing worked.

I installed xampplite 1.7.0 on my computer at work but I cannot run it.
Path is C:/xampp/...etc
MySql is running w/o problem as the consol disaplays "running" after clicking on Start.

About installation and things I tried to solve this problem
1. I installed xampplite 1.7.0 using the .exe file in C:, then I renamed "xampplite" folder to xampp
2. Modify regedit: in HKEY_LOCAL_MACHINE/SOFTWARE/ I created "xampp" folder and add a new key "Install_Dir" with value "C:\xampp"
3. I changed the skype connection options to avoid it using ports 80 and 443
>> Before running xampp I check port status with xampp-portcheck.exe tool, all ports are "free"
>>> I also tried without running Skype at all to double check (including 4).
4. I tried also to edit C:\xampp\apache\conf\httpd.conf and httpd-ssl.conf and assign new port as 8080 and 4499, and tried also other config as it did not worked...
5. I disabled the firewall

At home I installed same version of xampp on Win7, I only had to do 1. 2. and 3. to get Apache started correctly. No need to edit other file or assign different ports to Apache.

I can also say I am using the IE 8.0, lotus notes (I also tried w/o running it but it seems there is no problem with it...)
As said in the subject title, I have XP SP3 (in japanese but no this should not be a problem)

Any clue to solve this? Did I make wrong settings?

I forgot to say, IE8 displays: "Internet Explorer cannot display the webpage"
Alex45
 
Posts: 5
Joined: 29. June 2011 08:07
Location: Japan - TKY

Re: Can't run Apache with xampplite 1.7.0 on XP SP3

Postby Sharley » 01. July 2011 10:31

Alex45 wrote:1. I installed xampplite 1.7.0 using the .exe file in C:, then I renamed "xampplite" folder to xampp
Did you run the setup_xampp.bat file in the xampp folder after changing the installation location folder?
This bat file process will set the new paths from xampplite to xampp.

Check the C:\xampp\apache\logs\error.log file to see if it mentions this changed location.

Also check in the C:\xampp\apache\conf\htdocs\httpd.conf file and see if the paths reflect your changed installation location - the bat file should change every path that had xampplite to xampp for you.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't run Apache with xampplite 1.7.0 on XP SP3

Postby Alex45 » 04. July 2011 02:30

Hi, thank you very much for your help.

Did you run the setup_xampp.bat file ?

>> Yes, but it says "Sorry but... nothing to do". I refreshed it after changing the folder name from "xampplite" to "xampp"

Check the C:\xampp\apache\logs\error.log file to see if it mentions this changed location.

>> This file content is always blank... I don't know why but It may give some clue(?).

Also check in the C:\xampp\apache\conf\htdocs\httpd.conf file and see if the paths reflect your changed installation location (...)

>> I think you ment this path C:\xampp\apache\conf\httpd.conf
I checked it many times. Every paths are starting with C:\xampp\..
And other important lines are as follows:
#Listen 12.34.56.78:80 >> do I have to change it with 127.0.0.1 ?
Listen 80
(...)
ServerName localhost:80

Now I have a question about typographical marks, I am not sure whether it will lead to a solution but...
I said that, the same configuration worked at home, however I have a windows 7 (french vers.)
At work I use a japanese WIN XP O.S and the path is not written with slash but yen mark: C:xampp¥apache¥conf
I am not sure whether this is important or not as it may be only a matter of code because when I copy/paste directly on this board
it shows slash and not yen mark C:xampp/apache/conf and vice and versa.

In the file "httpd.conf" it is written in the 4th paragraph as follows:
# NOTE: Where filenames are specified, you must use forward slashes
# instead of backslashes (e.g., "c:/apache" instead of "c:\apache").
# If a drive letter is omitted, the drive on which Apache.exe is located
# will be used by default. It is recommended that you always supply
# an explicit drive letter in absolute paths, however, to avoid
# confusion.


Any new idea?

-Alex-
Alex45
 
Posts: 5
Joined: 29. June 2011 08:07
Location: Japan - TKY

Re: Can't run Apache with xampplite 1.7.0 on XP SP3

Postby JonB » 04. July 2011 13:05

its just a thought, but you might check the 'hosts' file on your work computer to see if it is pointing localhost to 127.0.0.1

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Can't run Apache with xampplite 1.7.0 on XP SP3

Postby Alex45 » 05. July 2011 02:17

JonB wrote:its just a thought, but you might check the 'hosts' file on your work computer to see if it is pointing localhost to 127.0.0.1

8)


Hi Jon, thanks for your help.

I tried with #Listen 127.0.0.1 and restart everything but it didn't worked.
I read and read as many threads as possible regarding common problems with install of xamplite on XP SP3 but everything I tried did not solve my problem until now... I reinstall many times properly but it does not change as well.
I don't see where I made a mistake. (;_;)

What do you mean exactly by "hosts" file? This referes to Which files or which folder? Do you mean I need to check paths in a specific file?

Thanks for helping.

- Alex -
Alex45
 
Posts: 5
Joined: 29. June 2011 08:07
Location: Japan - TKY

Re: Can't run Apache with xampplite 1.7.0 on XP SP3

Postby JonB » 05. July 2011 13:50

Hi Alex


About the hosts file:

its found in different location based on the Windows OS you are running

http://support.microsoft.com/kb/972034

http://www.windowsreference.com/windows ... ows-vista/

In Most cases it is found in c:\windows\system32\drivers\etc

IT DOES NOT HAVE ANY EXTENSION! - so you will have to start a text editor FIRST, and then navigate with the Open File command.

it should have a line that says:

Code: Select all
127.0.0.1      localhost


Unless your machine has more than one NIC (network Interface), your Listen directive can be simply 'Listen 80' (or any other open port).

Good Luck


8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Can't run Apache with xampplite 1.7.0 on XP SP3

Postby Alex45 » 06. July 2011 05:33

Hi Jon,

Thanks again for your comments

I copy the file on the desktop and rename host.txt so I could open it easily.
It is written as you said: 127.0.0.1 localhost
:arrow: Only one line for localhost.

I give up with xampplite 1.7.0 ...
I'll try a different version and let you know.

Thank you very much again!
Alex45
 
Posts: 5
Joined: 29. June 2011 08:07
Location: Japan - TKY

Re: Can't run Apache with xampplite 1.7.0 on XP SP3

Postby Alex45 » 06. July 2011 06:01

Jon, Sharley,

I installed xampp 1.7.0, - not lite vers. - and both Apache and Mysql are running.
I didn't make other changes, no restart of the computer.
I suppose some setting was missing for installation of lite version.

happy at the end :)

Thank you for your support again.
-Alex-
Alex45
 
Posts: 5
Joined: 29. June 2011 08:07
Location: Japan - TKY


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests