Help Plss ASAP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Help Plss ASAP

Postby kalaiyappan » 27. June 2011 10:30


1. I have installed XAMPP in my windows server 2003, and configured it in a port named 84 in IIS,It was running pretty well.Unknowingly the directory in which i installed xampp in IIS was deleted, and i am unable to view my website in server.I tried creating a new directory with the path "C:\XAMPP\htdocs" where my websites are residing.I am not sure whether the local path which i have given is correct??The directories and files which are residing on the folder is visible on accessing the site..could anyone please correct me if i am wrong in setting up this path??how to make my site run as it was running well previously

2. I am running Apache of XAMPP in 84. i.e i have configured in that way in httpd-conf file and i have also changed the port number to 442 in http ssl file.I tried starting from apache-start.bat file(which i learnt from previous forums) but it is throwing an error of make_sock:could not bind to address..:84 :cry:

with regards
Posts: 1
Joined: 27. June 2011 10:04

Re: Help Plss ASAP

Postby BigWetDog » 27. June 2011 14:44

First, your IIS and Apache configurations should be mutually exclusive of one another. They are both web servers, and therefore both are designed to handle http requests and they both can be configured to listen on whatever port you choose. It is precisely because you have the two servers configured to listen on the same port that Apache cannot start. If you started Apache first, IIS wouldn't be able to start.
If you truly are in a situation where you need both technologies for whatever purpose, then you MUST configure them to each listen on different ports. You can allow them to serve the same content by configuring them to use the same directories, again if it's necessary. If you don't require both, then pick one. Both IIS and XAMPP are capable of processing PHP, so if that is your language of choice, the server choice is up to you. Simplest solution to your problem is to change one or the other (but not both) back to port 80.
If you are determined to use XAMPP, then disable or remove IIS. That topic has been covered elsewhere, so please do a search or google.
As for your deleted directory, review your httpd.conf in the apache/conf directory of your XAMPP installation. Find the DocumentRoot element and that is the path where your content will be served from (unless you are using virtual hosts, which I doubt you are)
User avatar
Posts: 148
Joined: 25. February 2010 15:54

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 77 guests