Cant get localhost to work [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: Cant get localhost to work

Postby bigjohn2029 » 27. June 2011 21:37

Thanks for your help, Sharley!

1. Yes, both are running
2. Yes…funny enough the first time I couldn’t with the documents but now I could
3. Here is what the error reports suggest

[Mon Jun 27 19:45:23 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Jun 27 19:45:23 2011] [notice] Digest: done
[Mon Jun 27 19:45:24 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Jun 27 19:45:24 2011] [notice] Server built: Oct 18 2010 01:58:12
[Mon Jun 27 19:45:24 2011] [notice] Parent: Created child process 1548
[Mon Jun 27 19:45:24 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Jun 27 19:45:24 2011] [notice] Digest: done
[Mon Jun 27 19:45:25 2011] [notice] Child 1548: Child process is running
[Mon Jun 27 19:45:25 2011] [notice] Child 1548: Acquired the start mutex.
[Mon Jun 27 19:45:25 2011] [notice] Child 1548: Starting 150 worker threads.
[Mon Jun 27 19:45:25 2011] [notice] Child 1548: Starting thread to listen on port 443.
[Mon Jun 27 19:45:25 2011] [notice] Child 1548: Starting thread to listen on port 80.
[Mon Jun 27 19:47:24 2011] [error] [client 127.0.0.1] PHP Warning: file_get_contents(lang.tmp) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: No such file or directory in C:\\xampp\\htdocs\\xampp\\index.php on line 2
Adding password for user john
Adding password for user john
[Mon Jun 27 20:22:04 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/index.html
[Mon Jun 27 20:30:57 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs
[Mon Jun 27 20:32:13 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs
[Mon Jun 27 20:34:18 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs
[Mon Jun 27 20:42:57 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs

4. The answer to your 4th question is: http://localhost/xampp/htdocs/index.html
5. The answer to your 5th question is http://localhost/xampp/htdocs/promassag ... x_test.php
6.
7.
8. The website is an existing one. I didn’t develop it.
Hope this info helps?
bigjohn2029
 
Posts: 13
Joined: 24. June 2011 09:47

Re: Cant get localhost to work

Postby bigjohn2029 » 27. June 2011 21:49

Navigation to the webpage was canceled

What you can try:
Retype the address.


When I try to click on “Documentation” this is what comes up, the same for “Components”. Like I said it was working but the security page keeps coming up. I click the continue to this website
There is a problem with this website's security certificate.


The security certificate presented by this website was not issued by a trusted certificate authority.

Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server.
We recommend that you close this webpage and do not continue to this website.
Click here to close this webpage.

Continue to this website (not recommended).

More information




Your guess is as good as mine. Im stumped!
bigjohn2029
 
Posts: 13
Joined: 24. June 2011 09:47

Re: Cant get localhost to work

Postby Sharley » 27. June 2011 21:50

Drop the /xampp/htdocs from the URI and you should be all set to move forward.
http://localhost/index.html
http://localhost/promassagetherapy.co.uk/public_html/index_test.php
localhost = the C:\xampp\htdocs folder
localhost/promassagetherapy.co.uk = the C:\xampp\htdocs\promassagetherapy.co.uk folder

The server knows this because the DocumentRoot as defined in the httpd.conf file is C:\xampp\htdocs, so no need to include it in your browser's URI.

BigJohn wrote:The security certificate presented by this website was not issued by a trusted certificate authority.
The localhost Apache server has it's own self signed SSL certificate so the warning can be ignored or you can accept the certificate permanently in this case but out on the big Internet it would be a 'different gether all to case' :).

You can find the SSL certificate in C:\xampp\apache\conf\ssl.crt folder and the configuration file in the C:\xampp\apache\conf\extra\httpd-ssl.conf file - so no secret agendas in the security of the Localhost web server. :)

Only you can access localhost so no issues there.


Hope this helps clear up these issue and you can move on.

Regards.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Cant get localhost to work

Postby bigjohn2029 » 28. June 2011 06:32

You are fantastic!! :D They both indeed work!! Ive been trying to sort this out for over a week now! Once again I apologize from before. Thanks again. I should be ok now...famous last words. LOL
bigjohn2029
 
Posts: 13
Joined: 24. June 2011 09:47

Re: Cant get localhost to work

Postby Sharley » 28. June 2011 06:44

Your welcome John and alls well that ends well. :)

If you do have issues further down the track and they are XAMPP related then don't hesitate to raise another topic here and some knowledgeable forum member will surely respond.

Good luck and best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests