Admin Accessibility Issue

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Admin Accessibility Issue

Postby JKDesignGC » 20. June 2011 15:43

Hello All,
First poster to Apache Friends boards, here. I have been using XAMPP for windows for a few years now though, and might I say, I love XAMPP!

I do at this time, however, have an issue and request assistance solving it. I have looked through the forums for about an hour an a half searching diligently, and have spent many more hours on the web generally searching for same. The solution may indeed exist in these forums but I despair of my ability to form the correct search to find it. I will pose the issue here, and be as informative as possible while being (hopefully) succinct. I thank you in advance for your assistance.

OS - Windows 7 Pro 64bit on two separate machines. (They display issue similarly but not identically)
XAMPP version - XAMPP 1.7.4 for Windows.
Installation in C:/xampp
Default Browser Firefox 4.0.1
Apache running as a Service (Green and functioning 'thumbs up')
MySQL running as a Service (Green and functioning 'thumbs up')

In each case localhost will serve my web pages with their PHP scripts running with no issue. The problems comes when I try to access Admin for Apache. I hit the Admin button in the Control Panel and it opens my default browser Firefox to location http://localhost/xampp/ as it should, but I get:

Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.
Error 500
6/20/2011 9:24:04 AM
Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1

Second issue is with MySQL Admin button not doing anything at all. I AM able to navigate browser directly to http://localhost/phpmyadmin/ and can view phpMyAdmin properly.

Perhaps these are related or perhaps they are not. I included it all here together for purposes of expediency and completeness. I appreciate any help you can give. I am feeling pretty beaten up by this, and just can't seem to overcome it on my own.

All The Best,
Posts: 2
Joined: 20. June 2011 14:13

Re: Admin Accessibility Issue

Postby JonB » 20. June 2011 19:11

I'm not 100% sure, but I think there were problems with the Control Panel on 64 bit machines.

read this thread -


Good Luck
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Admin Accessibility Issue

Postby JKDesignGC » 20. June 2011 20:07

JonB, the v3.0.2 Control Panel is MARVELOUS! Corrected the issue with the MySQL Admin accessibility.

I actually seem to have discovered the solution to the issue with the Server Error 500 on Apache. I managed to get into /localhost/security/ and change the password information for the main Apache directory and that solved the issue. I did not expect that to do the trick but it did. I am using the zip version of XAMPP, and there was probably something to do regarding that in the set up process that I did not manage to take care of.

For now I think I am all cleared up. I thank you most graciously for your response.
Posts: 2
Joined: 20. June 2011 14:13

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 76 guests