Strange Error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Strange Error

Postby Jere » 20. June 2011 03:44

Hi!

I want to try out Joomla with Xampp so I downloaded Joomla into the htdocs folder, went to my browser onto localhost/Joomla and the Joomla instalation came up. All good until now. The thing is, I cant get passed the Database Configuration page, this is what it gives me:

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM CHARACTER SET `utf8`' at line 29 SQL=CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default '0', `type` varchar(30) NOT NULL default 'banner', `name` varchar(255) NOT NULL default '', `alias` varchar(255) NOT NULL default '', `imptotal` int(11) NOT NULL default '0', `impmade` int(11) NOT NULL default '0', `clicks` int(11) NOT NULL default '0', `imageurl` varchar(100) NOT NULL default '', `clickurl` varchar(200) NOT NULL default '', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default '0', `checked_out` tinyint(1) NOT NULL default '0', `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00', `editor` varchar(50) default NULL, `custombannercode` text, `catid` INTEGER UNSIGNED NOT NULL DEFAULT 0, `description` TEXT NOT NULL DEFAULT '', `sticky` TINYINT(1) UNSIGNED NOT NULL DEFAULT 0, `ordering` INTEGER NOT NULL DEFAULT 0, `publish_up` datetime NOT NULL default '0000-00-00 00:00:00', `publish_down` datetime NOT NULL default '0000-00-00 00:00:00', `tags` TEXT NOT NULL DEFAULT '', `params` TEXT NOT NULL DEFAULT '', PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`), INDEX `idx_banner_catid`(`catid`) ) TYPE=MyISAM CHARACTER SET `utf8`


Does anyone know why?

Im using Xampp 1.7.4 and Joomla 1.5.23.

Please help!! Thanks!!
Jere
 
Posts: 1
Joined: 20. June 2011 03:37

Re: Strange Error

Postby JonB » 20. June 2011 04:18

read this thread:

http://forum.joomla.org/viewtopic.php?t=195859

the upshot - the MySQL version you have installed with XAMPP no longer supports the DB declaration 'Type ='
Change Type= to Engine= in the .sql file (or installation code) to fix this issue.

http://bugs.mysql.com/bug.php?id=17501

That may mean you need to patch the Joomle code - the right place to address that is in the Joomla Forums.

Whenever you see "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' TYPE=MyISAM CHARACTER SET `utf8`' at line 29

IT MEANS EXACTLY THAT - MySQL does not understand your syntax (what you are asking it to do). and the next couple of words is going to tell you WHAT mySQL does not understand.

OK its Offical:
Removed Features:
•The table_type system variable (use storage_engine).
http://dev.mysql.com/doc/refman/5.5/en/ ... shell.html

HMMM - this is probably due to the MySQL 5.5's switch to InnoDb as the default Database Engine (table type). There I go calling it a table type, LOL.

Good Luck
' 8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: hthnightwolf and 64 guests