XAMPP permissions Windows 7 Ioncube Package Foundry

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP permissions Windows 7 Ioncube Package Foundry

Postby groovy » 16. June 2011 18:37

I am attempting to upload a file via FTP to my xampp installation from the very PC that holds the XAMPP install.

I am using an install exe process founded on Ioncube Package Foundry.

This is what it looks like.

I am using Windows 7. I am using XAMPP.

I have Filezilla FTP as a svc in the XAMPP control panel. I click on Admin... and it takes me to an interface that shows my server, via port 14147 to my 127.0.0.1

However when I try to upload something to my server I get 550 Internal error, permission denied to create directory. It tells me to check if the user has permissions in the target folder.

Through port 14147 I can't see anything. Through port 21, the usual one for FTP, at least I can see a folder called 'incoming'.

I have tried setting permissions to total control in the folders of my Windows 7 I want to upload my files to. Like the 'incoming' folder. But no luck.

I have tried whitening the read-only feature of the folders of my XAMPP install. This gives me a sort of error when I try to apply it to the entire XAMPP install, but seems to work when I do it to smaller ones, like the 'incoming' or the 'htdocs' ones, which I was thinking of FTPing to. But whenever I return to properties after applying and exiting, the read-only checkbox feature is still blackened.

One of the basic contradictions is the users I create in XAMPP are one thing and the users in Windows 7 would seemingly be accounts you create in Windows 7. Why am I trying to enable permissions to windows accounts when I should be finding a way to enable permissions to XAMPP users? Question is how?

I would greatly appreciate any help on this matter. :| :| :| :| :| :|
groovy
 
Posts: 2
Joined: 16. June 2011 16:46

Re: XAMPP permissions Windows 7 Ioncube Package Foundry

Postby Sharley » 17. June 2011 01:40

Windows file/folder permissions set in the XAMPP installation are stock standard and do not need any tweaking on your part and that's why they are returned to the defaults after you try and change them - in Windows, unlike Linux, permissions are mostly irrelevant.

You need to make sure that your FTP Server is configured correctly for your needs by perhaps reading some of the posts here:
http://forum.filezilla-project.org/viewforum.php?f=6
Or perhaps here:
help with setting up a filezilla server

What FTP Client do you normally use, as the FileZilla Client seems to be a perfect match?

FTP Server errors like the error 550 are displayed in the log window of the server config albeit without much detail as to why you get this error.

By default, permission to upload, for an default anon user is restricted to the 'incoming' folder and outside this folder will give the 550 error - doing anything like deleting a file in the 'incoming' folder will also give a 550 error, unless you change this behavior.

BTW the 'incoming' folder is located in \xampp\anonymous\incoming

As mentioned, you will need to change all behavior for any user/group by using the Settings in your FTP server configuration by creating a user/pass with their respective upload/download folders and permissions for those folders clearly defined, as you will need to do for the default anon user - you are the server's administrator so you need to get a handle on what you are administrating.

Port 21 is correct to connect to your server by default in your Client software, the other port is used for data so you will not see a directory listing if you enter this in the server's address in your client.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP permissions Windows 7 Ioncube Package Foundry

Postby groovy » 17. June 2011 08:57

Thanks. Your reply made me think it over and it turned out to be the FTP shared folder config, NOT anything in Windows...

It was staring right under my nose at me all the time, under a tab.

However, one click next I'm at an another issue. When prompted for:

'This installer needs a web server for some tasks

You entered 'incoming/'' for the install location on your FTP server. Please enter the URL of the install location on your web server.

Install location URL: http://

I write in something like http://localhost/myfolder

and other variations. I even try taking my install exe to myfolder but it always gives me the following message:

''a folder 'ipf-work-dir-13922343452 has been created but cannot be located on the web server xampp

please adjust the url so that it points to the location of the package install folder on the web, then click Next to retry.''
groovy
 
Posts: 2
Joined: 16. June 2011 16:46


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests