Yet another 'could not bind to port 80' error.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Yet another 'could not bind to port 80' error.

Postby Infernus666 » 13. June 2011 22:55

Hello,

There probably have been a lot more issues like that, I've googled around, but haven't really found the correct solution. What I am experiencing is that I can with my XAMP run mysql, but never Appache. No, I do not have Skype, however I do have other instant messaging applications such as XFire and Windows Live Messenger. I don't know if those use port 80, I've tried shutting all instant messaging services down, but still didn't work.

You can see my error below:

error wrote:(OS 10013)Er is geprobeerd toegang te verkrijgen tot een socket op een volgens de toegangsmachtigingen niet toegestane manier. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

translated error wrote:(OS 10013)There was an attempt to get access to a socket on the access-granted manner. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs


Hmm, well, as you can see my translation skills aren't really that good, so I hope this is clear enough to understand.


I would really appreciate some help on this error, as I am wanting to set up a site on my localhost. Thanks in advance.
Infernus666
 
Posts: 2
Joined: 13. June 2011 22:46

Re: Yet another 'could not bind to port 80' error.

Postby Altrea » 13. June 2011 23:04

So you have to find out which process is listening on port 80.
There are several possibilities:
- use the netstat command in your windows command line as described here
- use the great netstat tool included in the new XAMPP control panel v3.0.2
- use the XAMPP portcheck
- use any other software which can show you used ports on your computer
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Yet another 'could not bind to port 80' error.

Postby Infernus666 » 13. June 2011 23:23

It wasn't a process causing this. It was a service causing this. For people who have gave up hope like I did:

1) run cmd.exe
2) input 'services.msc' and hit enter
3) disable 'World Wide Web Publishing-service'

Hope that's going to help some people!
Infernus666
 
Posts: 2
Joined: 13. June 2011 22:46

Re: Yet another 'could not bind to port 80' error.

Postby Sharley » 14. June 2011 06:07

If the need arises again to see what is using the ports that XAMPP requires exclusively, use this nice little freeware no-install portable app. CurrPorts from here:
http://www.nirsoft.net/utils/cports.html
This little app. is/was the underlying application used in XAMPP's own port checker - works very well and gives you easy control over the ports, unlike some of the other methods offered here - you may also like some of the many free utilities available from the above linked web site.

Infernus666 wrote:It wasn't a process causing this. It was a service causing this. For people who have gave up hope like I did:

1) run cmd.exe
2) input 'services.msc' and hit enter
3) disable 'World Wide Web Publishing-service'

Hope that's going to help some people!
This can also be done from within the XAMPP Control Panel using the SCM (Service Control Manager) button or in the newer version 3 Control Panel you would use the Win-Services button.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests