Error #2002 from phpMyAdmin 1.7.2 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error #2002 from phpMyAdmin 1.7.2 [SOLVED]

Postby bobcox » 05. June 2011 15:11

I've just re-installed V1.7.2 (after having problems with 1.7.4) and when trying to access phpMyAdmin I get this error message:

MySQL said:
#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

Connection for controluser as defined in your configuration failed.

The server appears to be running as shown on the Control Panel, so can someone please outline how to check and correct the server's socket.

Thanks
bobcox
 
Posts: 2
Joined: 05. June 2011 15:05

Re: Error from phpMyAdmin (sever not responding

Postby bobcox » 05. June 2011 16:12

Solved my own problem.

Not sure why but the setup seems to have changed so that you need to log in to use phpMyAdmin using username and password (original setup did not require this)
Modified appropriate line in config.inc.php line to $cfg['Servers'][$i]['auth_type'] = 'cookie'; (was 'config') and the sytem works
bobcox
 
Posts: 2
Joined: 05. June 2011 15:05

Re: Error #2002 from phpMyAdmin 1.7.2 [SOLVED]

Postby Sharley » 07. November 2011 11:21

Thanks for your feedback and self solving, magic.8)

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 93 guests