WSDL/nusoap not operating

Problems with the Windows version of XAMPP, questions, comments, and anything related.

WSDL/nusoap not operating

Postby dgrab » 26. May 2011 17:13

Took an exising PHP application which runs successfully on Windows Server 2008 r2 and IIS/MySQL to XAMPP for portability.

Most everything works as-is. I have two issues:

1. opening a wsdl file in a browser being served by XAMPP Apache tries to download versus being shown in the browser, which would indicate that I have a mime type issue. However, setting to text/xml for wsdl (and restarting apache) still has the same issue. Am thinking it's related to my second issue,
2. no nusoap calls work; am guessing that it's due to apache not processing the wsdl. Ideas?

Again, application works on other platform, and I need to get these issues addressed. Appreciate any help and assistance!

Thanks!
dgrab
 
Posts: 2
Joined: 26. May 2011 17:07

Re: WSDL/nusoap not operating

Postby joalglok » 02. October 2012 18:42

U have to enable the isapi_module.

in your httpd.conf check that the module is loaded
"LoadModule isapi_module modules/mod_isapi.so"

and in IfModule mime_module section add a handler for the .dll files
"AddHandler isapi-handler .dll"

restart Apache and it should work now :D
joalglok
 
Posts: 1
Joined: 02. October 2012 18:34
XAMPP Version: 5.5.19
Operating System: Windows and Linux

Re: WSDL/nusoap not operating

Postby dgrab » 02. October 2012 18:52

Thanks, will give that a shot!
dgrab
 
Posts: 2
Joined: 26. May 2011 17:07


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 41 guests