cant load the index file in http://localhost directory

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: cant load the index file in http://localhost directory

Postby vanheusen » 22. May 2011 18:45

in XAMPP control panel, there is a button that says admin.
I clicked, and it was suppose to load http://localhost but again, I got the browser empty page error
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Re: cant load the index file in http://localhost directory

Postby Altrea » 22. May 2011 18:54

vanheusen wrote:in XAMPP control panel, there is a button that says admin.

No, thats not what i want.

- Please close your control panel if it is open )complete, not to tray).
- Open your Explorer
- go into your XAMPP installation directory
- Hold down your CTRL + Shift Key
- Doubleclick on your xampp-control.exe file

thats a shortcut for running an application as Administrator
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: cant load the index file in http://localhost directory

Postby vanheusen » 22. May 2011 19:01

alright
Located xampp-control.exe
double clicked it with ctl+shift buttons pressed
both Apache, and MySQL are running with the green lights on
again, tried loading localhost in the browser to no avail
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Re: cant load the index file in http://localhost directory

Postby Altrea » 22. May 2011 19:06

Have you checked any of the SVC checkboxes in your control panel?
Are you sure, that there is not another Apache running on your Computer?

Please stop your Apache and take again a look into your \xampp\apache\logs\ folder if it is still empty.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: cant load the index file in http://localhost directory

Postby vanheusen » 22. May 2011 19:12

what is SVC?
there's no other Apache running on my computer
Checked the log directory, and it is empty
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Re: cant load the index file in http://localhost directory

Postby Altrea » 22. May 2011 19:22

vanheusen wrote:what is SVC?

In your control panel there is left of each single component a checkbox to register windows services (short: svc)

vanheusen wrote:there's no other Apache running on my computer
Checked the log directory, and it is empty

Your Apache can't run without these log files.
So why should your control panel show you that your Apache is running if it isn't?

There are just two possibilities left, i know:
Check your Windows Task Manager (CTRL+SHIFT+Esc) processes tab for any apache.exe or httpd.exe process running.

Check out the new XAMPP Control Panel v3.0.2 if that give you any more information about whats going on.

After that i've no idea left.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: cant load the index file in http://localhost directory

Postby vanheusen » 23. May 2011 00:01

Hi there
And thank you so much for all your help.
so, I run the windows task manager, and cant see the apache.exe, nor the other one running. However, the XAMPP control panel does show both the MYSQL, and Apache servers running with a check mark to their left, and a green light showing.
Would you suggest to uninstall, and reinstall the XAMPP?? do you know of a better site to download it from?
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Re: cant load the index file in http://localhost directory

Postby Altrea » 23. May 2011 00:15

vanheusen wrote:the XAMPP control panel does show both the MYSQL, and Apache servers running with a check mark to their left, and a green light showing.

Try to stop Apache and MySQL by clicking the "Stop" Buttons in the control panel.
After that uncheck the checkboxes in the control panel if they are checked.
Now try again to start Apache and MySQL with their "Start" Buttons.

If that will not help, then maybe a fresh installation can help.
Maybe you should use the older XAMPP 1.7.3 which was much more stable than the current XAMPP 1.7.4.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: cant load the index file in http://localhost directory

Postby vanheusen » 23. May 2011 00:32

It worked
You'r awsome man..
Thanx a million
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Re: cant load the index file in http://localhost directory

Postby Altrea » 23. May 2011 00:57

You're welcome 8)
Have fun with XAMPP and all that stuff.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 23 guests