cant load the index file in http://localhost directory

Problems with the Windows version of XAMPP, questions, comments, and anything related.

cant load the index file in http://localhost directory

Postby vanheusen » 21. May 2011 16:49

I fired off the XAMPP control panel, all apache, mysquel, filezilla are running and have the green light on.
when I type in the adress http://localhost/ the browser gives me Oops! Google Chrome could not connect to localhost. I tried in various browsers, and they are all in the online mode.. to no avail.
However, when I go into the xampp directory, and double click on the index file it loads it.

Any suggesttions?
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Re: cant load the index file in http://localhost directory

Postby Altrea » 21. May 2011 19:56

please try out if http://127.0.0.1/ is working
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: cant load the index file in http://localhost directory

Postby vanheusen » 21. May 2011 23:03

Tried it... it doesnt work.
As I said, Apache, and MySQL both have the green light
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Re: cant load the index file in http://localhost directory

Postby Altrea » 22. May 2011 00:34

So, you tried 127.0.0.1 on the computer where XAMPP is installed on, is that correct?
Are you really really sure your Apache is running? Please try a portcheck for port 80 with netstat in your Windows command prompt (the full command is described here).
Have you changed anything at the configuration of your Apache?
Have you running any security software (personal firewall, virus protection)?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: cant load the index file in http://localhost directory

Postby vanheusen » 22. May 2011 01:08

I turned off both my virus protection agent, and the fire wall to no avail
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Re: cant load the index file in http://localhost directory

Postby Altrea » 22. May 2011 05:16

Without answering all of my questions i can't help you.
This is no multiple choice test :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: cant load the index file in http://localhost directory

Postby vanheusen » 22. May 2011 14:22

Yes my friend, i tried the netstat -o it said "Established" i turned off my virus protection, and the fire wall that comes with it. Same problem
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Re: cant load the index file in http://localhost directory

Postby Altrea » 22. May 2011 15:05

You should read the post first i linked in my previous post here.
netstat -o is not enough.

it's difficult enough to solve problems of someone else. If you don't help me to help you, it is impossible and i just can give up.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: cant load the index file in http://localhost directory

Postby vanheusen » 22. May 2011 16:25

Ok
I run the whole netstat -aon |find ":80"
and what i got was like 14 lines of:
TCP ##### ##### ESTABLISHED

there wasn't any reference to port 80 whatsoever
My skype, virus detection and firewall are both off
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Re: cant load the index file in http://localhost directory

Postby Altrea » 22. May 2011 17:18

Okay, so if you don't have any "LISTENING" (not ESTABLISHED) connection on port 80, there are two possibilities:

1st: Apache is running on a different port (you have changed the configuration) on that computer.
2nd: Apache is not running on any port on that computer.

Please take a look into your \xampp\apache\logs\error.log file if there is anything in it about his own starting attempts.
If you don't know what all can be interesting in that file, post the whole contents here.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: cant load the index file in http://localhost directory

Postby vanheusen » 22. May 2011 17:34

\xampp\apache\logs\
I checked the "Logs" folder, and its empty. Hence, i presume there are no errors generated
also
I havent played with any configurations.. I installed it a ran it.. thats all
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Re: cant load the index file in http://localhost directory

Postby Altrea » 22. May 2011 17:49

Apache generates the log files automatically at the first start and the error.log file contains log entries if it can start successfully too.
If the logs folder is empty, there are again two possibilities:
- Apache never tries to start
- Apache hasn't the permissions to create the files

If you use a Windows OS with the new UAC (User Account control) like Windows Vista, Seven, Server 2008:
- turn off your UAC
- rightclick your XAMPP Control Panel icon and choose "Run as Administrator"
- try to start Apache and MySQL
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: cant load the index file in http://localhost directory

Postby vanheusen » 22. May 2011 18:19

Im using windows vista home basic
How can I turn off UAC to beging with?
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Re: cant load the index file in http://localhost directory

Postby Altrea » 22. May 2011 18:24

Google is your friend:
http://www.petri.co.il/disable_uac_in_windows_vista.htm

I prefer Method #4
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: cant load the index file in http://localhost directory

Postby vanheusen » 22. May 2011 18:40

Alright.. so UAX is off.
I tried right clicking on the XAMPP icon in the tray but I dont get a menu for that.
I went to the main XAMPP control, and I noticed there's no run as administrator option in there as well.
vanheusen
 
Posts: 13
Joined: 21. May 2011 16:27

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 74 guests