Apache cant start. Port 80 in use

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache cant start. Port 80 in use

Postby janyk » 14. May 2011 09:16

Hello everybody.

I cant start apache
Here is my CurrentPorts result:

Image

What should i do?

(Sorry for my bad english)
User avatar
janyk
 
Posts: 6
Joined: 14. May 2011 09:06

Re: Apache cant start. Port 80 in use

Postby Sharley » 14. May 2011 09:32

Usually means there is Windows Service using port 80.

viewtopic.php?f=16&t=46656

Try a reboot it often works.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache cant start. Port 80 in use

Postby janyk » 14. May 2011 09:35

Sharley wrote:Usually means there is Windows Service using port 80.

viewtopic.php?f=16&t=46656

Try a reboot it often works.


I have rebooted my PC but it still isnt working :S
And i dont have installed IIS

Image(Yeah, im dutch so my windows is dutch)
User avatar
janyk
 
Posts: 6
Joined: 14. May 2011 09:06

Re: Apache cant start. Port 80 in use

Postby Sharley » 14. May 2011 09:44

The screen cap in your first post is XAMPP's port check not CurrPorts.

Download CurrPorts from here and run it as it may tell you exactly what is using port 80:
http://www.nirsoft.net/utils/cports.html
You may be able to download a version in your own language.
http://www.nirsoft.net/utils/trans/cports_dutch.zip
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache cant start. Port 80 in use

Postby janyk » 14. May 2011 09:48

Sharley wrote:The screen cap in your first post is XAMPP's port check not CurrPorts.

Download CurrPorts from here and run it as it may tell you exactly what is using port 80:
http://www.nirsoft.net/utils/cports.html
You may be able to download a version in your own language.
http://www.nirsoft.net/utils/trans/cports_dutch.zip


Image
User avatar
janyk
 
Posts: 6
Joined: 14. May 2011 09:06

Re: Apache cant start. Port 80 in use

Postby Sharley » 14. May 2011 10:00

viewtopic.php?p=179735#p179735
One has the local and remote address as 0.0.0.0 and the other one simply has :: as the local and remote address
from the link I provided above if you had cared to read it as the actual offender was IIS and when properly disabled fixed the issue - Also known as World Wide Publishing.

viewtopic.php?p=180068#p180068
It was the IIS that was causing the issues. Running smooth now.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache cant start. Port 80 in use

Postby janyk » 14. May 2011 10:05

Sharley wrote:http://community.apachefriends.org/f/viewtopic.php?p=179735#p179735
One has the local and remote address as 0.0.0.0 and the other one simply has :: as the local and remote address
from the link I provided above if you had cared to read it as the actual offender was IIS and when properly disabled fixed the issue - Also known as World Wide Publishing.

viewtopic.php?p=180068#p180068
It was the IIS that was causing the issues. Running smooth now.

So what do I do now? Install and uninstall IIS?
User avatar
janyk
 
Posts: 6
Joined: 14. May 2011 09:06

Re: Apache cant start. Port 80 in use

Postby Sharley » 14. May 2011 10:10

Here are the 2 methods that I am aware of:

To disable IIS go to
Start>Control Panel>Programs and Features
on the leftmost side you will find an option
Turn Windows features on or off
click on it and uncheck
Internet Information Services
click OK
and then restart your computer.


- open "inetmgr"
- expand your computer
- expand sites
- right-click the default web site
-- select stop (XP)
-- manage web site --> select stop (Vista/7)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache cant start. Port 80 in use

Postby janyk » 14. May 2011 10:13

Sharley wrote:Here are the 2 methods that I am aware of:

To disable IIS go to
Start>Control Panel>Programs and Features
on the leftmost side you will find an option
Turn Windows features on or off
click on it and uncheck
Internet Information Services
click OK
and then restart your computer.


- open "inetmgr"
- expand your computer
- expand sites
- right-click the default web site
-- select stop (XP)
-- manage web site --> select stop (Vista/7)



But IIS is disabled!
Image
User avatar
janyk
 
Posts: 6
Joined: 14. May 2011 09:06

Re: Apache cant start. Port 80 in use

Postby Sharley » 14. May 2011 10:19

...but the World Wide Publishing Windows Service may yet not be disabled unless you have already disabled in using the Service Control Manager.
viewtopic.php?p=175526#p175526

viewtopic.php?p=135356#p135356


Or may be you have some malware that has hijacked port 80 but it is not an XAMPP issue so you will have to locate what is using port 80 and disable it before you can move forward.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Problem resolved! Re: Apache cant start. Port 80 in use

Postby janyk » 14. May 2011 11:07

Thanks for your help,it was the
Web Deployment Agent Service (MsDepSvc) service

I have disabled it and now the port is free
Thanks for your help again!
User avatar
janyk
 
Posts: 6
Joined: 14. May 2011 09:06

Re: Apache cant start. Port 80 in use

Postby GlennC » 23. September 2011 22:11

Yes, this was my culprit.

I downloaded V3 of the control panel, as instructed by the experts here at Apache Friends, and it was very helpful. The Netstat showed that "system" was using port 80, but didn't show exactly what that was.

I went to the task manager and showed tasks for "All Users". I started killing process that I though were safe and likely to tie up port 80. Then I'd check back with Netstat to see if it's free. It was the "Web Deployment Agent Service", MSDepSvc.exe.

For work purposes, I have to use IIS frequently. So instead of turning off the service, I use IIS Manager to stop my local instance. Apparently, this process hangs on.

Good job on Control Panel V3, guys!

== XAMPP Win32 1.7.7
== XAMP Control Panel v3.0.2
== Windows 7 PC
GlennC
 
Posts: 4
Joined: 16. September 2011 01:45

Re: Apache cant start. Port 80 in use

Postby JonB » 23. September 2011 22:21

For work purposes, I have to use IIS frequently. So instead of turning off the service, I use IIS Manager to stop my local instance.


Good Idea -
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 75 guests