Can I update just the php version?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can I update just the php version?

Postby mikidudle » 12. May 2011 19:02

First, thank you for reading and answering in English. I appreciate it.

Can I upgrade just the php to newer verison? Do I have to upgrade whole XAMPP? How do I do that without loosing all database info?
I have loaded Mambo 4.6.5 into the system and I get a fatal error. I think that's because Mambo needs php of higher version.
I have Control Panel version 2.5.8, XAMPP for Windows version 1.7.3, Windows 5.1 build 2600 Platform 2 Service Pack 3. If you care, Mambo version is 4.6.5.

Best of Thanks!
Besten Dank

Mike :roll:
mikidudle
 
Posts: 1
Joined: 12. May 2011 18:49

Re: Can I update just the php version?

Postby Altrea » 13. May 2011 00:09

mikidudle wrote:Can I upgrade just the php to newer verison?

No, you can't.

mikidudle wrote:Do I have to upgrade whole XAMPP?

No, you have to install a complete new XAMPP Package, because there is no upgrade package from XAMPP 1.7.3 to XAMPP 1.7.4.

mikidudle wrote:How do I do that without loosing all database info?

Backups, backups and even more backups (!!)
- make an image of your whole harddisk (just to be safe)
- copy your xampp\\mysql\data\ folder to a secure place
- export your Databases with mysqldump, MySQLDumper or phpmyadmin

the easiest way to bring your databases to a newer MySQL Installation is to copy your Database files from one mysql\data folder to the new one.
But you can reimport them from your Database Exports too. It's up to you.

Remember to create the Database Users is needed too!

mikidudle wrote:I have loaded Mambo 4.6.5 into the system and I get a fatal error. I think that's because Mambo needs php of higher version.

Mambo 4.6.5 was released 2008-07-01
PHP 5.3.1 (which is part of XAMPP 1.7.3) was released 2009-11-19
so i don't think that a newer Version will do the trick for you. But a downgrade to XAMPP 1.7.1 maybe helps (some Scripts have some problem with PHP 5.3.x)

Read the Mambo System Requirements
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 71 guests