problems with apache ssl port 443 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

problems with apache ssl port 443 [SOLVED]

Postby mconi2007 » 09. May 2011 06:34

I tried to start apache, and it gives an error saying the Apache ssl port 443 is blocked. It is installed but it cannot start. Please help!!!!!!!!!!!!!!!!
mconi2007
 
Posts: 9
Joined: 26. April 2011 10:56

Re: problems with apache ssl port 443

Postby Sharley » 09. May 2011 06:45

I tried to start apache, and it gives an error saying the Apache ssl port 443 is blocked.
What give an error saying...?

Where do you see this error message about port 443?

Read the xammp\apache\logs\error.log file at about the date and time you last tried to start Apache for more details about your error.

If port 443 or any port that XAMPP requires is already in use then this will prevent Apache etc. from starting.

To see what is using the ports that XAMPP requires exclusively, use this nice little freeware no-install app. CurrPorts from here:
http://www.nirsoft.net/utils/cports.html
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: problems with apache ssl port 443

Postby mconi2007 » 09. May 2011 07:19

On the the Services interface, when i try to start the Apache2 service,the bar moves then stops and returns an error message saying Apache SSL port 443 is blocked. In the log file there is no record of this error.
mconi2007
 
Posts: 9
Joined: 26. April 2011 10:56

Re: problems with apache ssl port 443

Postby Sharley » 09. May 2011 07:23

What is the "Services interface" and why are you trying to start Apache using it instead of using the XAMPP Control Panel?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: problems with apache ssl port 443

Postby mconi2007 » 09. May 2011 07:36

When I used the xampp control panel, when I click start, it tells me Apache started. It shows Running then stops with no error message. The services in terface is where all the installed services can be seen, started or stopped. I decided to there directly to start Apache2, that when it showed the error message
"Apache SSL prot 443 blocked".
mconi2007
 
Posts: 9
Joined: 26. April 2011 10:56

Re: problems with apache ssl port 443

Postby Sharley » 09. May 2011 07:50

Some other server is using port 443 and CurrPorts will tell you what it is - Skype?

Only use the XAMPP Control Panel but first you will have to find out and disable what is using port 80 and port 443 as we can't possibly do that from here.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: problems with apache ssl port 443

Postby mconi2007 » 17. May 2011 10:45

Yeah, Thanks Sharley its working fine now, the port was being occupied by skype so I stopped it and started the apache server and its working perfectly. Thanks again for your help Sharley. Melvin
mconi2007
 
Posts: 9
Joined: 26. April 2011 10:56

Re: problems with apache ssl port 443

Postby Sharley » 17. May 2011 10:52

Melvin, that's good news.

If you start Apache before Skype then Skype will use other ports.

Also you can configure Skype to use other ports so you can have both running, which I am sure you would prefer.

Good Luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests

cron