problem with apache port number not working on windows 7

Problems with the Windows version of XAMPP, questions, comments, and anything related.

problem with apache port number not working on windows 7

Postby speedgogo » 08. May 2011 21:16

hi, I tried changing the port number from 80 to 8888 in C:\xampp\apache\conf\httpd.conf file and it didn't work at all. also I check the status and its still 80 port of apache and I can't really restart my apache since its not working at all and it says
"can't find process c:\xampp\apache\bin\httpd.exe"

So I don't know what to do now.
speedgogo
 
Posts: 1
Joined: 08. May 2011 21:09

Re: problem with apache port number not working on windows 7

Postby Sharley » 09. May 2011 00:57

You should put the httpd.conf file back to the default settings and anything else you changed so you at least know that this configuration file is now without any changes you may have made that will in future cause issues.

Ignore the port 80 status message in the XAMPP Control Panel as it is hard coded.

Do read the C:\xampp\apache\logs\error.log file and look for clues why Apache can't start at about the date and time you last tried to start it, usually because there is another server on port 80 that needs to be disabled like Skype, World Wide Publishing (IIS) or any number of apps that are now using port 80 by default - Apache can't share port 80.

To see what is using the ports that XAMPP requires exclusively, use this nice little freeware no-install app. CurrPorts from here:
http://www.nirsoft.net/utils/cports.html
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests