Problems with apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems with apache

Postby hikzero » 25. April 2011 00:55

I am running Windows 7 64-bit, and I installed xampp into c:\xampp

Earlier I had problems with apache not starting because port 80 was being occupied by my teamviewer and skype instances, but I took care of that and after that http://localhost worked, however only when started apache with c:\xampp\xampp_start.exe (and obviously stopped apache with xampp_stop.exe).

when i start xampp through the gui (c:\xampp\xampp-control.exe), i get the message "XAMPP component status failure [3]. Current directory: C:\xampp run this program only from your XAMPP root directory"

I find this odd because as far as I know, I am running xampp from the root directory.

When it opens (regardless if i do it as an administrator or not), I try to start apache, and it says: "ERROR: Apache service not started [-1]"

and 127.0.0.1:80 does not work.

My httpd.conf file has not been touched

My apache error.log file:

Code: Select all
[Sat Apr 23 22:59:26 2011] [notice] Digest: generating secret for digest authentication ...
[Sat Apr 23 22:59:26 2011] [notice] Digest: done
[Sat Apr 23 22:59:28 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Apr 23 22:59:28 2011] [notice] Server built: Oct 18 2010 01:58:12
[Sat Apr 23 22:59:29 2011] [notice] Parent: Created child process 6900
Apache server shutdown initiated...
Digest: generating secret for digest authentication ...
[Sat Apr 23 22:59:30 2011] [notice] Digest: done
[Sat Apr 23 22:59:31 2011] [notice] Child 6900: Child process is running
[Sat Apr 23 22:59:31 2011] [notice] Child 6900: Acquired the start mutex.
[Sat Apr 23 22:59:31 2011] [notice] Child 6900: Starting 150 worker threads.
[Sat Apr 23 22:59:31 2011] [notice] Child 6900: Starting thread to listen on port 443.
[Sat Apr 23 22:59:31 2011] [notice] Child 6900: Starting thread to listen on port 80.
[Sat Apr 23 22:59:36 2011] [error] [client 127.0.0.1] PHP Warning:  file_get_contents(lang.tmp) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: No such file or directory in C:\\xampp\\htdocs\\xampp\\index.php on line 2
[Sat Apr 23 23:54:59 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sat Apr 23 23:54:59 2011] [notice] Child 6900: Exit event signaled. Child process is ending.
[Sat Apr 23 23:55:00 2011] [notice] Child 6900: Released the start mutex
[Sat Apr 23 23:55:01 2011] [notice] Child 6900: All worker threads have exited.
[Sat Apr 23 23:55:01 2011] [notice] Child 6900: Child process is exiting
[Sat Apr 23 23:55:01 2011] [notice] Parent: Child process exited successfully.
[Sun Apr 24 01:16:15 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Apr 24 01:16:15 2011] [notice] Digest: done
[Sun Apr 24 01:16:17 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Apr 24 01:16:17 2011] [notice] Server built: Oct 18 2010 01:58:12
[Sun Apr 24 01:16:17 2011] [notice] Parent: Created child process 8980
[Sun Apr 24 01:16:19 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Apr 24 01:16:19 2011] [notice] Digest: done
[Sun Apr 24 01:16:20 2011] [notice] Child 8980: Child process is running
[Sun Apr 24 01:16:20 2011] [notice] Child 8980: Acquired the start mutex.
[Sun Apr 24 01:16:20 2011] [notice] Child 8980: Starting 150 worker threads.
[Sun Apr 24 01:16:20 2011] [notice] Child 8980: Starting thread to listen on port 443.
[Sun Apr 24 01:16:20 2011] [notice] Child 8980: Starting thread to listen on port 80.
[Sun Apr 24 01:36:07 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sun Apr 24 01:36:07 2011] [notice] Child 8980: Exit event signaled. Child process is ending.
[Sun Apr 24 01:36:08 2011] [notice] Child 8980: Released the start mutex
[Sun Apr 24 01:36:09 2011] [notice] Child 8980: All worker threads have exited.
[Sun Apr 24 01:36:09 2011] [notice] Child 8980: Child process is exiting
[Sun Apr 24 01:36:09 2011] [notice] Parent: Child process exited successfully.
[Sun Apr 24 01:42:52 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Apr 24 01:42:52 2011] [notice] Digest: done
[Sun Apr 24 01:42:54 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Apr 24 01:42:54 2011] [notice] Server built: Oct 18 2010 01:58:12
[Sun Apr 24 01:42:54 2011] [notice] Parent: Created child process 4784
[Sun Apr 24 01:42:55 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Apr 24 01:42:55 2011] [notice] Digest: done
[Sun Apr 24 01:42:56 2011] [notice] Child 4784: Child process is running
[Sun Apr 24 01:42:56 2011] [notice] Child 4784: Acquired the start mutex.
[Sun Apr 24 01:42:56 2011] [notice] Child 4784: Starting 150 worker threads.
[Sun Apr 24 01:42:56 2011] [notice] Child 4784: Starting thread to listen on port 443.
[Sun Apr 24 01:42:56 2011] [notice] Child 4784: Starting thread to listen on port 54321.
[Sun Apr 24 01:44:22 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sun Apr 24 01:44:22 2011] [notice] Child 4784: Exit event signaled. Child process is ending.
[Sun Apr 24 01:44:23 2011] [notice] Child 4784: Released the start mutex
[Sun Apr 24 01:44:24 2011] [notice] Child 4784: All worker threads have exited.
[Sun Apr 24 01:44:24 2011] [notice] Child 4784: Child process is exiting
[Sun Apr 24 01:44:24 2011] [notice] Parent: Child process exited successfully.
[Sun Apr 24 02:06:50 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Apr 24 02:06:50 2011] [notice] Digest: done
[Sun Apr 24 02:06:51 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Apr 24 02:06:51 2011] [notice] Server built: Oct 18 2010 01:58:12
[Sun Apr 24 02:06:51 2011] [notice] Parent: Created child process 4444
Apache server shutdown initiated...
Digest: generating secret for digest authentication ...
[Sun Apr 24 02:06:53 2011] [notice] Digest: done
[Sun Apr 24 02:06:54 2011] [notice] Child 4444: Child process is running
[Sun Apr 24 02:06:54 2011] [notice] Child 4444: Acquired the start mutex.
[Sun Apr 24 02:06:54 2011] [notice] Child 4444: Starting 150 worker threads.
[Sun Apr 24 02:06:54 2011] [notice] Child 4444: Starting thread to listen on port 443.
[Sun Apr 24 02:06:54 2011] [notice] Child 4444: Starting thread to listen on port 80.
[Sun Apr 24 02:09:00 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/iDungeon, referer: http://www.powerbot.org/vb/showthread.php?t=727682
[Sun Apr 24 02:09:01 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/iDungeon, referer: http://www.powerbot.org/vb/showthread.php?t=727682
[Sun Apr 24 02:09:51 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sun Apr 24 02:09:51 2011] [notice] Child 4444: Exit event signaled. Child process is ending.
[Sun Apr 24 02:09:52 2011] [notice] Child 4444: Released the start mutex
[Sun Apr 24 02:09:53 2011] [notice] Child 4444: All worker threads have exited.
[Sun Apr 24 02:09:53 2011] [notice] Child 4444: Child process is exiting
[Sun Apr 24 02:09:53 2011] [notice] Parent: Child process exited successfully.



Need some help,

hikzero
hikzero
 
Posts: 3
Joined: 25. April 2011 00:37

Re: Problems with apache

Postby hikzero » 26. April 2011 19:46

Anyone?
hikzero
 
Posts: 3
Joined: 25. April 2011 00:37

Re: Problems with apache

Postby Altrea » 26. April 2011 20:03

[Sun Apr 24 02:09:00 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/iDungeon, referer: http://www.powerbot.org/vb/showthread.php?t=727682

You are the only one who can explain, why the request is going for a iDungeon folder

[Sun Apr 24 02:06:54 2011] [notice] Child 4444: Starting thread to listen on port 80.

Your Apache was listening on port 80 until you exited it.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problems with apache

Postby hikzero » 26. April 2011 23:12

I honestly don't know.

I have no such folder:

Image

Does subversion or git programs/websites have anything to do with this? That project was a java thing from git/svn.

Is there some way to troubleshoot that query?
hikzero
 
Posts: 3
Joined: 25. April 2011 00:37

Re: Problems with apache

Postby Altrea » 27. April 2011 04:53

hikzero wrote:I have no such folder:

Sure, you haven't. Thats what your Apache is telling you!
But the million dollar question is: Why does your Apache expected to request such a folder?
Nobody can know, exept of you. We don't have configured your Apache.

I don't know what this iDungeon is for and why the referer to your computer comes from http://www.powerbot.org/vb/showthread.php?t=727682. Doesn't make a serious impression on me, something like real world trading for an online game.

hikzero wrote:Does subversion or git programs/websites have anything to do with this?

That depends on how you have configured Apache to work with svn/git. But very common: no, thats not an issue.

hikzero wrote:Is there some way to troubleshoot that query?

Sure, find out where this iDungeon on your computer comes from and how to get rid of that.

But again: Maybe you don't have an issue at all! Your Apache received requests and logged them to his logfile. So your Apache is/was working on port 80! Maybe you just have an issue with the XAMPP Administration Backend. There is another line in your Apache error log which can be an indication for such an issue:
[Sat Apr 23 22:59:36 2011] [error] [client 127.0.0.1] PHP Warning: file_get_contents(lang.tmp) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: No such file or directory in C:\\xampp\\htdocs\\xampp\\index.php on line 2
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests