Localhost-Apache works sometimes

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Localhost-Apache works sometimes

Postby bizeesheri » 21. April 2011 14:30

I had been running apache fine for several weeks. Tuesday night, I installed Wordpress on my local machine without incident. Kind of big deal for me, a novice to this local host testing. Yesterday I got home and the local host sites wouldn't come up and multiple reboots apache wouldn't start. I don't have Skype. I finally got it running. Not sure what changed.???

The next issue. I have a website created for me, php and mysql driven with a CMS. and I want to bring it to my machine. I copied all the files to a htdocs folder. There is an index.php. Now I did import the mysql database via myphpadmin, but whether that works, I don't know.

I also created a virtual host entry (as I did with localhost and wordpress)

I even tried to open a hello.php file and that won't work.
--------------------------------------------------------------------------
http://localhost/iv-7/hello.php gets a 500 error
http://localhost/iv-7 gets a 500 error

http://localhost/wordpress/ works!

I double checked and the index and all other files are in htdocs/iv-7


the only files I have opened are the httpd.conf and httpd-vhosts.conf
===========================
Apache Error Log: [Thu Apr 21 05:42:18 2011] [alert] [client 127.0.0.1] C:/xampp/htdocs/iv-7/.htaccess: IndexIgnore not allowed here
=========================
<VirtualHost *:80>

DocumentRoot "c:/xampp/htdocs"
ServerName localhost
<Directory "c:/xampp/htdocs" >

Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
DocumentRoot "c:/xampp/htdocs/iv-7"
ServerName iv-7
<Directory "c:/xampp/htdocs/iv-7">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>

DocumentRoot "c:/xampp/htdocs/wordpress"
ServerName wordpress
<Directory "c:/xampp/htdocs/wordpress">

Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>
</VirtualHost>
============================================
bizeesheri
 
Posts: 2
Joined: 21. April 2011 14:03

Re: Localhost-Apache works sometimes

Postby bizeesheri » 22. April 2011 01:10

I believe I solved it.

After problem solving all day, I realized from a search re: IndexIgnore not allowed here
that it was something in the htaccess file.

So when I got home today,

I didn't touch that file. I did a search and found several in fact throughout that directory. I changed to them all to htaccess.txt so I wouldn't lose them.

That fixed it.

Now why I have those throughout my site, i dont know, since most are the same information. As I said I didn't create the site.

Anyhow, that solved it!
bizeesheri
 
Posts: 2
Joined: 21. April 2011 14:03


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests