Apache run error?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache run error?

Postby D-Con » 18. April 2011 22:09

First off I'm new to the forum so hello!
second I just Installed XAMPP so I could use it to run Wordpress on my own local server.
this is my first time using XAMPP I have tried several things that I found online and none of them work.
So let me get to my problem.

when ever I go to run the XAMPP Control Panel I get this pop up message:

Image

so I simply click the continue button and the Control Panel opens.
However, when I try to start Apache the green "running" indicator pops up
but then disappears right away and I get a busy message(seen in the image bellow)

before and after clicking "start"
Image

I'm running Windows 7
I'm running XAMPP 1.7.4 I used the installer.

I have checked and I'm not running anything on port 80
I have even tried shutting down FireFox and still nothing.

Here is my error Report:

[Sat Nov 27 09:11:11 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Nov 27 09:11:11 2010] [notice] Digest: done
[Sat Nov 27 09:11:12 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Nov 27 09:11:12 2010] [notice] Server built: Nov 11 2009 14:29:03
[Sat Nov 27 09:11:12 2010] [notice] Parent: Created child process 9140
[Sat Nov 27 09:11:15 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Nov 27 09:11:15 2010] [notice] Digest: done
[Sat Nov 27 09:11:15 2010] [notice] Child 9140: Child process is running
[Sat Nov 27 09:11:15 2010] [notice] Child 9140: Acquired the start mutex.
[Sat Nov 27 09:11:15 2010] [notice] Child 9140: Starting 150 worker threads.
[Sat Nov 27 09:11:15 2010] [notice] Child 9140: Starting thread to listen on port 443.
[Sat Nov 27 09:11:15 2010] [notice] Child 9140: Starting thread to listen on port 443.
[Sat Nov 27 09:11:15 2010] [notice] Child 9140: Starting thread to listen on port 80.
[Sat Nov 27 09:11:15 2010] [notice] Child 9140: Starting thread to listen on port 80.
[Sat Nov 27 09:14:33 2010] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sat Nov 27 09:14:33 2010] [notice] Child 9140: Exit event signaled. Child process is ending.
[Sat Nov 27 09:14:34 2010] [notice] Child 9140: Released the start mutex
[Sat Nov 27 09:14:35 2010] [notice] Child 9140: All worker threads have exited.
[Sat Nov 27 09:14:35 2010] [notice] Child 9140: Child process is exiting
[Sat Nov 27 09:14:35 2010] [notice] Parent: Child process exited successfully.
[Sat Nov 27 09:14:40 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Nov 27 09:14:40 2010] [notice] Digest: done
[Sat Nov 27 09:14:41 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Nov 27 09:14:41 2010] [notice] Server built: Nov 11 2009 14:29:03
[Sat Nov 27 09:14:41 2010] [notice] Parent: Created child process 9160
[Sat Nov 27 09:14:43 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Nov 27 09:14:43 2010] [notice] Digest: done
[Sat Nov 27 09:14:43 2010] [notice] Child 9160: Child process is running
[Sat Nov 27 09:14:43 2010] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sat Nov 27 09:14:43 2010] [notice] Child 9160: Acquired the start mutex.
[Sat Nov 27 09:14:43 2010] [notice] Child 9160: Starting 150 worker threads.
[Sat Nov 27 09:14:43 2010] [notice] Child 9160: Exit event signaled. Child process is ending.
[Sat Nov 27 09:14:44 2010] [error] (OS 10038)An operation was attempted on something that is not a socket. : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sat Nov 27 09:14:44 2010] [error] (OS 10038)An operation was attempted on something that is not a socket. : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sat Nov 27 09:14:44 2010] [error] (OS 10038)An operation was attempted on something that is not a socket. : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sat Nov 27 09:14:44 2010] [error] (OS 10038)An operation was attempted on something that is not a socket. : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sat Nov 27 09:14:44 2010] [notice] Child 9160: Released the start mutex
[Sat Nov 27 09:14:45 2010] [notice] Child 9160: All worker threads have exited.
[Sat Nov 27 09:14:46 2010] [notice] Child 9160: Child process is exiting
[Sat Nov 27 09:14:46 2010] [notice] Parent: Child process exited successfully.
[Sat Nov 27 09:16:35 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Nov 27 09:16:35 2010] [notice] Digest: done
[Sat Nov 27 09:16:36 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Nov 27 09:16:36 2010] [notice] Server built: Nov 11 2009 14:29:03
[Sat Nov 27 09:16:36 2010] [notice] Parent: Created child process 5416
[Sat Nov 27 09:16:39 2010] [notice] Digest: generating secret for digest authentication ...
[Sat Nov 27 09:16:39 2010] [notice] Digest: done
[Sat Nov 27 09:16:39 2010] [notice] Child 5416: Child process is running
[Sat Nov 27 09:16:39 2010] [notice] Child 5416: Acquired the start mutex.
[Sat Nov 27 09:16:39 2010] [notice] Child 5416: Starting 150 worker threads.
[Sat Nov 27 09:16:39 2010] [notice] Child 5416: Starting thread to listen on port 443.
[Sat Nov 27 09:16:39 2010] [notice] Child 5416: Starting thread to listen on port 443.
[Sat Nov 27 09:16:39 2010] [notice] Child 5416: Starting thread to listen on port 80.
[Sat Nov 27 09:16:39 2010] [notice] Child 5416: Starting thread to listen on port 80.
[Sat Nov 27 09:20:55 2010] [error] [client ::1] script 'C:/xampp/htdocs/test.php' not found or unable to stat
[Sat Nov 27 09:20:55 2010] [error] [client ::1] File does not exist: C:/xampp/htdocs/favicon.ico
[Sat Nov 27 09:20:55 2010] [error] [client ::1] File does not exist: C:/xampp/htdocs/favicon.ico
[Sat Nov 27 09:20:58 2010] [error] [client ::1] File does not exist: C:/xampp/htdocs/favicon.ico
Syntax error on line 125 of C:/xampp/apache/conf/extra/httpd-xampp.conf:
The specified IP address is invalid.
Syntax error on line 125 of C:/xampp/apache/conf/extra/httpd-xampp.conf:
The specified IP address is invalid.

any help would be greatly appreciated!
D-Con
 
Posts: 1
Joined: 18. April 2011 21:56

Re: Apache run error?

Postby swappie » 29. April 2011 09:49

I had the same problem. I've recently installed Visual Studio 2010 Express and it installs the IIS 7 extension named "Web Deploy Command Line". That started a service on my Windows machine with the name "Web Deployment Agent Service". I went to Run -> accessed "service.msc" and just stopped that service. Now the apache on XAMPP runs awesome. I spent a lot of time until I figured this out...

However, if you're having Windows 7 on your machine, you can check if there's a running process named: "World Wide Web Publishing Service". Just stop that and it'll work then. Moreover, if you're running Skype, search on google how you can set it up to make xampp work. :D
swappie
 
Posts: 1
Joined: 29. April 2011 09:41

Re: Apache run error?

Postby WilliL » 29. April 2011 13:35

did you read: http://community.apachefriends.org/f/viewtopic.php?f=16&t=44320?
... there are a lot of hints
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests