Installing older php version on XAMPP 1.7.4

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Installing older php version on XAMPP 1.7.4

Postby dala » 12. April 2011 10:28

I installed XAMPP 1.7.4 on my server. I need the "Alternative PHP Cache" (APC). Since this was not included by default in XAMPP 1.7.4 I had to download the new version of php_apc.dll.
I got APC running, but I keep getting an errormessage ("Potential cache slam averted for key"). I Googled this errormessage and I see that it can appears due to a bug, and that php 5.3.5 is (also) affected by this bug. (Has this got something to do with why APC is not included in XAMPP 1.7.4 by default, maybe?)

Anyways, on my development machine I installed XAMPP 1.7.3 which uses php 5.3.1. Here APC is included by default and it works without no problem.
Therefore I want to install php 5.3.1 instead of 5.3.5 on my server as well.
Can I simply download the older php version and overwrite the new one in my XAMPP 1.7.4 installation, or will this cause any problems?
What is the easiest way to install php 5.3.1 instead of 5.3.5 on XAMPP 1.7.4?

Thanks in advance for any help
dala
 
Posts: 6
Joined: 11. April 2011 09:26

Re: Installing older php version on XAMPP 1.7.4

Postby Sharley » 12. April 2011 10:45

dala wrote:Therefore I want to install php 5.3.1 instead of 5.3.5 on my server as well.
Can I simply download the older php version and overwrite the new one in my XAMPP 1.7.4 installation, or will this cause any problems?
What is the easiest way to install php 5.3.1 instead of 5.3.5 on XAMPP 1.7.4?
Sorry to say that is not entirely possible as php is compiled into Apache as a module.

The simplest way is to uninstall 1.7.4 from your server then install XAMPP 1.7.3 version, is it not? :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Installing older php version on XAMPP 1.7.4

Postby dala » 12. April 2011 10:52

Maybe it is.
I just hoped I could avoid having to setup things from scratch again, but maybe it isn't too big a job...
dala
 
Posts: 6
Joined: 11. April 2011 09:26

Re: Installing older php version on XAMPP 1.7.4

Postby Sharley » 12. April 2011 10:57

It would be an even bigger job to compile php into maybe an incompatible Apache version - best to use the XAMPP versions that the developers have compiled as they test that each component is compatible and works (most of the time ;) ).

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Installing older php version on XAMPP 1.7.4

Postby dala » 12. April 2011 12:02

Ok, I have now installed XAMPP 1.7.3 instead like you suggested. Took me about half 45 minutes I guess to configure things, so it wasn't THAT bad afterall :)
And now APC works, which is what I needed.

Thanks again!
dala
 
Posts: 6
Joined: 11. April 2011 09:26

Re: Installing older php version on XAMPP 1.7.4

Postby Sharley » 12. April 2011 12:20

Your welcome and I am also pleased about this good outcome.

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests