Error : "Windows cannot access the specified device.."

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error : "Windows cannot access the specified device.."

Postby DanielG » 10. April 2011 10:36

Hi,

I'm getting this error from XAMPP. After installation, it just says "Cannot find specified device.".

Image

Error log is as follows :
Code: Select all
[Sun Apr 10 17:14:02 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Apr 10 17:14:02 2011] [notice] Digest: done
[Sun Apr 10 17:14:03 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Apr 10 17:14:03 2011] [notice] Server built: Oct 18 2010 01:58:12
[Sun Apr 10 17:14:03 2011] [notice] Parent: Created child process 2364
[Sun Apr 10 17:14:05 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Apr 10 17:14:05 2011] [notice] Digest: done
[Sun Apr 10 17:14:06 2011] [notice] Child 2364: Child process is running
[Sun Apr 10 17:14:06 2011] [notice] Child 2364: Acquired the start mutex.
[Sun Apr 10 17:14:06 2011] [notice] Child 2364: Starting 150 worker threads.
[Sun Apr 10 17:14:06 2011] [notice] Child 2364: Starting thread to listen on port 443.
[Sun Apr 10 17:14:06 2011] [notice] Child 2364: Starting thread to listen on port 80.


I've tried reinstallation, cleaning up the registry of "xampp" entries and also ensured port 80 is unused.

Does anyone have a solution for this?

Thanks in advance.
DanielG
 
Posts: 3
Joined: 10. April 2011 10:26

Re: Error : "Windows cannot access the specified device.."

Postby Sharley » 10. April 2011 10:51

Your log file looks normal and Apache looks like it is running.

Try going to http://localhost in your browser and select your language then see if the demos work.

Try running the setup-xampp.bat file in the xampp folder - it may say nothing to do and that will be fine and means it was used correctly when you installed XAMPP.

Did you try a reboot after installing XAMPP?

For your error message see if there is any help in these Google search results as this may well be a Windows OS issue not an XAMPP fault - could be a Windows security setting issue and these results may have the solution.

You look to be using XAMPP 1.7.4 but what Windows OS version are you using?

Are you using ZoneAlarm by any chance?

Are you logged into your computer as an Administrator not a User?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Error : "Windows cannot access the specified device.."

Postby peterwt » 10. April 2011 13:16

The Windows error you are getting relates to the control panel executable - xampp-control.exe.
Does the control panel open? If so try running control-panel.exe as an administrator - right click control-panel.exe and select "Run as Administrator", assuming you are signed in to Windows in an Administrator account.

If the control panel does not run when you get the error you showed how did you start Apache - as Sharley said it appears from the log that Apache is running.

Peter
Peter
peterwt
 
Posts: 42
Joined: 17. March 2009 11:06
Operating System: Windows 7 64 bit Professional

Re: Error : "Windows cannot access the specified device.."

Postby DanielG » 10. April 2011 18:49

Sharley wrote:Your log file looks normal and Apache looks like it is running.

Try going to http://localhost in your browser and select your language then see if the demos work.

Try running the setup-xampp.bat file in the xampp folder - it may say nothing to do and that will be fine and means it was used correctly when you installed XAMPP.

Did you try a reboot after installing XAMPP?

For your error message see if there is any help in these Google search results as this may well be a Windows OS issue not an XAMPP fault - could be a Windows security setting issue and these results may have the solution.

You look to be using XAMPP 1.7.4 but what Windows OS version are you using?

Are you using ZoneAlarm by any chance?

Are you logged into your computer as an Administrator not a User?


Yep, I can access localhost from the browser so Apache is running. I'm using Windows 7 Pro 64 bit, no ZoneAlarm but running Kaspersky Internet Security.

Logged in as a domain user with local admin rights. Also ran the exe in administrator mode.
DanielG
 
Posts: 3
Joined: 10. April 2011 10:26

Re: Error : "Windows cannot access the specified device.."

Postby DanielG » 10. April 2011 18:50

peterwt wrote:The Windows error you are getting relates to the control panel executable - xampp-control.exe.
Does the control panel open? If so try running control-panel.exe as an administrator - right click control-panel.exe and select "Run as Administrator", assuming you are signed in to Windows in an Administrator account.

If the control panel does not run when you get the error you showed how did you start Apache - as Sharley said it appears from the log that Apache is running.

Peter


The control panel doesn't open, even using "Run as Administrator".

Strangely Apache still starts. Quite puzzled too.
DanielG
 
Posts: 3
Joined: 10. April 2011 10:26

Re: Error : "Windows cannot access the specified device.."

Postby Sharley » 10. April 2011 23:17

DanielG wrote:Kaspersky Internet Security
Try and temporarily disable Kaspersky then start xampp-control.exe again and if it starts then you know now that you will need to configure Kaspersky to allow this file to be accessed.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Error : "Windows cannot access the specified device.."

Postby peterwt » 10. April 2011 23:23

How strange. I am using Windows 7 Pro 64 bit also but xampp 1.7.3


As apache is running but you have not started it then it appears you have somehow got apache running as a service, which would start it on every boot up. Check the services.

Peter
Peter
peterwt
 
Posts: 42
Joined: 17. March 2009 11:06
Operating System: Windows 7 64 bit Professional

Re: Error : "Windows cannot access the specified device.."

Postby DBBlogger » 09. June 2011 09:33

Sharley wrote:
DanielG wrote:Kaspersky Internet Security
Try and temporarily disable Kaspersky then start xampp-control.exe again and if it starts then you know now that you will need to configure Kaspersky to allow this file to be accessed.


Dear Ms Sharley,

Thank you very much for the Kaspersky advise. Installation worked after setting credentials in Kaspersky.
DBBlogger
 
Posts: 1
Joined: 09. June 2011 09:22


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests