Index page blank using Akeeba on Xampp localhost

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Index page blank using Akeeba on Xampp localhost

Postby tplowe » 09. April 2011 17:03

I have used Akeeba BU/Kickstart to install a local version of my site running on Xampp. The install goes smoothly, and the back end works fine, but my index page is blank with no code displaying in the page source. I am using the RocketTheme Crystalline template. I have another site also using Crystalline that runs fine on Xampp.
Details:
Joomla 1.5.18
Gantry 3.0.8
Crystalline 1.5

Code: Select all
In "configuration.php" I change error reporting to see errors:
var $error_reporting = '-1';
To this:
var $error_reporting = '2048';
 

I get this error log:

Strict Standards: Non-static method JLoader::import() should not be called statically in C:\xampp\htdocs\carmanbay\libraries\loader.php on line 186

Strict Standards: Non-static method JLoader::register() should not be called statically in C:\xampp\htdocs\carmanbay\libraries\loader.php on line 71

Strict Standards: Non-static method JLoader::load() should not be called statically in C:\xampp\htdocs\carmanbay\libraries\loader.php on line 161

Strict Standards: Non-static method JLoader::register() should not be called statically in C:\xampp\htdocs\carmanbay\libraries\loader.php on line 138

The complete error log is very lengthy. So Xampp must be working properly, (since it works on other site) and the DB must be OK since the back end is working fine. Anyone have any suggestions??
tplowe
 
Posts: 3
Joined: 09. April 2011 15:52

Re: Index page blank using Akeeba on Xampp localhost

Postby tplowe » 09. April 2011 21:03

I've narrowed it down to the RocketTheme, Crystalline Template.

Other templates, work fine....and display the same error report if I turn it on. So the error report has nothing to do with the problem. I have post up at RocketTheme, thanks.
tplowe
 
Posts: 3
Joined: 09. April 2011 15:52

Re: Index page blank using Akeeba on Xampp localhost

Postby Sharley » 10. April 2011 01:38

tplowe wrote:...I have post up at RocketTheme, thanks.
Could you please post here the link to your post at the RocketTheme forum so it may help others who are searching this forum for a solution or a clue and who may have a similar issue as yours - really so they can follow up on any help given at the RocketTheme forums.

Thanks muchly. :)

Just to add, what version of XAMPP and is your issue perhaps PHP version related ie. php 5.3.* and if so perhaps an older version of XAMPP with php 5.2.* may help.
There has recently been issues (posts in this forum) of this version kind with Joomla, it's themes and extensions that have been solved in the short term by running an older version of XAMPP that had version php 5.2.* and in the long term an updated Joomla and it's components to be compatible with php 5.3.* by their respective authors.

Good luck with it.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Index page blank using Akeeba on Xampp localhost

Postby tplowe » 10. April 2011 02:02

Here is the the post at RocketTheme: http://www.rockettheme.com/forum/index.php?f=334&t=129022&start=0&rb_v=viewtopic

Although after further investigations that are posted there. I have moved on.

I just tried the Akeeba BU into another directory on my server (not local) & the restore went fine. I'm going to quit investigating this problem on Xampp. Eating up too much time. I'll use the remote version for my development testing for the time being.
tplowe
 
Posts: 3
Joined: 09. April 2011 15:52


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 31 guests