Suddenly not recognizing any PHP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Suddenly not recognizing any PHP

Postby CubanComplex » 08. April 2011 01:27

I've been using XAMPP for months and it is a great product! However, two days ago I noticed that it is not recognizing any PHP. Pages I previously coded are not working wherever there is PHP coded, and even a test page I created named test.php with a simple php echo statement does not work.

I checked to see if PHP is activated and it is ACTIVATED. I checked to see what version of PHP was installed and it is PHP 5.3.1 enabled.

I have no idea how to go about resolving this. Any help will be greatly appreciated!
CubanComplex
 
Posts: 4
Joined: 08. April 2011 00:53

Re: Suddenly not recognizing any PHP

Postby Sharley » 08. April 2011 02:17

Is Apache showing a green running indication in the XAMPP Control Panel?

What do you see when you type http://localhost/xampp in your browser?

What are you typing in the browser to see your test.php page and where did you put this file in the xampp tree?

Any clues in the \xampp\apache\logs\error.log file?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Suddenly not recognizing any PHP

Postby CubanComplex » 08. April 2011 02:39

Apache is showing a green running indication.

Visiting http://localhost/xampp in my browser shows me the XAMPP for Windows screen; and visiting the Status screen shows me that PHP is ACTIVATED.

in my browser I type: http://localhost/test.php ---- I placed the file in the standard htdocs folder. I can bring up other files just fine, even pages that include PHP, but the parts with PHP do not display correctly.

I do not see anything out of the ordinary in \xampp\apache\logs\error.log
CubanComplex
 
Posts: 4
Joined: 08. April 2011 00:53

Re: Suddenly not recognizing any PHP

Postby Sharley » 08. April 2011 02:43

All, or just about all pages in the orange XAMPP Welcome page are php files and so are working as they should.

Paste the code from your test.php file and put all the code in between the forum's Code tags.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Suddenly not recognizing any PHP

Postby CubanComplex » 08. April 2011 02:53

Here are the contents of my test.php file.


Code: Select all
<?php
$str = "test";
echo $str;
echo "test2";
?>


It displays a completely blank page in Firefox 4.0, and in Chrome it just displays the actual text exactly as it can be read above.
CubanComplex
 
Posts: 4
Joined: 08. April 2011 00:53

Re: Suddenly not recognizing any PHP

Postby CubanComplex » 08. April 2011 02:58

Not sure what caused it, but I restarted my machine and it is now working!
CubanComplex
 
Posts: 4
Joined: 08. April 2011 00:53

Re: Suddenly not recognizing any PHP

Postby Sharley » 08. April 2011 03:04

Just tested this file in 1.7.4 and 1.7.3 versions of XAMPP and it gives the desired "testtest2" result.

Not sure what caused it, but I restarted my machine and it is now working!
Often the case and may be related to a Windows Update done in the background over the last couple of days.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests