php_network_getaddresses: getaddrinfo failed

Problems with the Windows version of XAMPP, questions, comments, and anything related.

php_network_getaddresses: getaddrinfo failed

Postby Rad » 04. April 2011 08:04

im getting this error when try acces my site:
php_network_getaddresses: getaddrinfo failed: No such host is known.
Img:
Image
i use windows 7 with sql 2005 express sp3
xaamp version 1.7.1
no clue what it can be,searched in internet the error but nothin, all i got is this but dk how to use it and what it do exactly
http://czetsuya-tech.blogspot.com/2009/08/phpnetworkgetaddresses-getaddrinfo.html

thx in advance
Last edited by Rad on 04. April 2011 08:38, edited 1 time in total.
Rad
 
Posts: 5
Joined: 04. April 2011 07:51

Re: php_network_getaddresses: getaddrinfo failed

Postby Sharley » 04. April 2011 08:22

What version of XAMPP have you installed?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: php_network_getaddresses: getaddrinfo failed

Postby Rad » 04. April 2011 08:32

version 1.7.1
Rad
 
Posts: 5
Joined: 04. April 2011 07:51

Re: php_network_getaddresses: getaddrinfo failed

Postby Sharley » 04. April 2011 08:39

What happens when you access http://localhost and then click on the demos in the left menu frame?

Trying to see if it is something wrong with the way you have setup your site database in phpMyAdmin.

Did you set your database Host to localhost or to Any Host % when you created it and your database user?

BTW the site IP in your screen cap is not accessible from the Internet.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: php_network_getaddresses: getaddrinfo failed

Postby Rad » 04. April 2011 08:51

Image


this the format when i use local.

the php my admin works fine. to be honest i dont know anything about php. this is coded by my friends i am just the hoster since they r not avaible i dunno what to do.

btw when i use different website which connects to my db i get the same problem.

if someone please please help me, and how to add the @ tag in apache to ignore the error??

i USE WINDOWS 7 WITH MS SQL 2005,XAMPP 1.7.1.
Rad
 
Posts: 5
Joined: 04. April 2011 07:51

Re: php_network_getaddresses: getaddrinfo failed

Postby Rad » 06. April 2011 06:21

bump- anyome can help me plz?
Rad
 
Posts: 5
Joined: 04. April 2011 07:51

Re: php_network_getaddresses: getaddrinfo failed

Postby WilliL » 06. April 2011 17:14

Rad wrote:if someone please please help me, and how to add the @ tag in apache to ignore the error??

have a look to error.log in c:/xampp/apache/logs (if standard configuration)
There you find hints to the script an line number where the error occures.

"$handle = @fopen($obj, "r");"
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: php_network_getaddresses: getaddrinfo failed

Postby Rad » 07. April 2011 12:13

WilliL wrote:
Rad wrote:if someone please please help me, and how to add the @ tag in apache to ignore the error??

have a look to error.log in c:/xampp/apache/logs (if standard configuration)
There you find hints to the script an line number where the error occures.

"$handle = @fopen($obj, "r");"


can u help me personally. seriously my website doesnot connect to teh database properly. i dont know y.. :(
Rad
 
Posts: 5
Joined: 04. April 2011 07:51


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests