I cannot see my site!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

I cannot see my site!

Postby dx4 » 01. April 2011 08:39

I've got a green running on apache, I also forwarded 80 and 443 ports on my router and when I try to see my page on another computer (not on the same network) I can't see anything, it says the page don't exist. What could be the problem?
dx4
 
Posts: 3
Joined: 01. April 2011 08:35

Re: I cannot see my site!

Postby Sharley » 01. April 2011 08:43

What are you typing in the browser of the other PC?

On the PC that XAMPP is installed on what do you see when you type http://localhost in your browser?

Any clues in the \xampp\apache\logs\error.log file?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: I cannot see my site!

Postby dx4 » 01. April 2011 09:23

I see normally the xampp interface and when I type localhost/index.html I see the default page "it works", but when I try that from another pc I don't see anything...
dx4
 
Posts: 3
Joined: 01. April 2011 08:35

Re: I cannot see my site!

Postby Sharley » 01. April 2011 09:29

Sharley wrote:What are you typing in the browser of the other PC?
http://localhost/index.html or http://localhost will only work on the PC that XAMPP is installed on - so you will have to use the LAN IP from other PC on the LAN or the IP address of your PC from the Internet.

Sharley wrote:Any clues in the \xampp\apache\logs\error.log file?
???
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: I cannot see my site!

Postby dx4 » 01. April 2011 10:38

Sharley wrote:
Sharley wrote:What are you typing in the browser of the other PC?
http://localhost/index.html or http://localhost will only work on the PC that XAMPP is installed on - so you will have to use the LAN IP from other PC on the LAN or the IP address of your PC from the Internet.

Sharley wrote:Any clues in the \xampp\apache\logs\error.log file?
???


I type a dyndns address that is pointed to my IP address on the other computer.

And this is the latest entry on the error.log file everything looks fine I think...
[Fri Apr 01 10:29:22 2011] [notice] Child 3396: Child process is running
[Fri Apr 01 10:29:22 2011] [notice] Child 3396: Acquired the start mutex.
[Fri Apr 01 10:29:22 2011] [notice] Child 3396: Starting 150 worker threads.
[Fri Apr 01 10:29:22 2011] [notice] Child 3396: Starting thread to listen on port 443.
[Fri Apr 01 10:29:22 2011] [notice] Child 3396: Starting thread to listen on port 80.
dx4
 
Posts: 3
Joined: 01. April 2011 08:35


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests