Frozen at startup?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Frozen at startup?

Postby Monchoman45 » 01. April 2011 01:10

Just downloaded XAMPP. Ran the installer .bat, it said everything was good. I followed the instructions for running Apache 2, and command prompt stops at "Apache 2 is starting up..." I tried going to http://localhost, and my browser stops at "waiting". Does anyone know what's going on, or how to fix it?
Monchoman45
 
Posts: 4
Joined: 01. April 2011 01:03

Re: Frozen at startup?

Postby Sharley » 01. April 2011 01:49

If you used the installer version then no need to run the setup_xampp.bat file and it will give a nothing to do message if you try.

Double click on the xampp-control.exe file and try and start Apache and MySQL from there.

Apache may not be starting for various reasons especially a port conflict with Skype and or World Wide Publishing (IIS).

Read the \xampp\apache\logs\error.log file to see if it has any clues.

Download this small free App which needs no installation, just run the exe file, it will give you info about what is using the ports 80, 443 and 3306 that XAMPP needs exclusively:
http://www.nirsoft.net/utils/cports.html
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Frozen at startup?

Postby Monchoman45 » 01. April 2011 02:31

Started Apache from the control panel like you said and it output "Apache started [Port 80]", but localhost still isn't loading.
Monchoman45
 
Posts: 4
Joined: 01. April 2011 01:03

Re: Frozen at startup?

Postby Sharley » 01. April 2011 02:45

Is Apache and MySQL showing a green running indication next to each of the names - ignore the text message in the box below?

What are you typing in your address bar of the browser?

Can you go to http://127.0.0.1 in your browser?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Frozen at startup?

Postby Monchoman45 » 01. April 2011 02:58

http://127.0.0.1 is also not working, and both Apache and MySQL have green running indications. I've been using http://localhost, in Chrome if that helps.
Monchoman45
 
Posts: 4
Joined: 01. April 2011 01:03

Re: Frozen at startup?

Postby Sharley » 01. April 2011 03:23

For some people there are unexplainable and unsolvable issues with using the installer version of XAMPP on some Windows version that is best solved by starting again with a clean uninstall and then using the zip version not the installer exe version of XAMPP.


So try this by uninstall this instance using the instruction in the readme_en.txt file in the xampp folder...
...when you have stopped all XAMPP components and removed any ticks in the Svc check boxes in the XAMPP Control Panel then you can EXIT the Control Panel and delete the xampp folder.



Now download the zip version of XAMPP and extract the xampp folder to the C:\ drive so you end up with C:\xampp

Now run the setup-xampp.bat file which will do some work then ask you to close it.

Next double click on the xampp-control.exe file and start Apache and MySQL only.

Now go to http://localhost and select your language and then see if you can do all the demos.

Let me know if by following the above instructions you still have problems.

BTW clear you browser's temporary file cache and do it often.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Frozen at startup?

Postby Monchoman45 » 01. April 2011 23:26

Reinstalled with the .zip, still can't go to http://localhost. However, this time when I tried to start up Apache, the console said it was running, but the running icon didn't appear and the button didn't change to stop. I clicked it again and it said "Warning: terminating worker thread 0", then it worked fine.
Monchoman45
 
Posts: 4
Joined: 01. April 2011 01:03


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests