Installing MyBB... Error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Installing MyBB... Error

Postby Rhineus » 24. March 2011 10:26

Hello,

I would like to test and do everything for MyBB locally until I get it online but I can't. It gives me this error:

MyBB SQL Error

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM CHARACTER SET utf8 COLLATE utf8_general_ci' at line 9
Query:
CREATE TABLE mybb_adminlog ( uid int unsigned NOT NULL default '0', ipaddress varchar(50) NOT NULL default '', dateline bigint(30) NOT NULL default '0', module varchar(50) NOT NULL default '', action varchar(50) NOT NULL default '', data text NOT NULL, KEY module (module, action) ) TYPE=MyISAM CHARACTER SET utf8 COLLATE utf8_general_ci;


I did give a mysql password via the phpmyadmin, I went to the tab "privileges" and gave both of the roots passwords. And set up XAMPP DIRECTORY PROTECTION as well. But I guess my firewall (Comodo Internet Security Premium) is blocking my access also. What can I do :?:

Thank You,
Michael
Rhineus
 
Posts: 3
Joined: 28. November 2010 11:30

Re: Installing MyBB... Error

Postby Sharley » 24. March 2011 10:31

First what version of XAMPP did you install?

Is the MySQL version in your XAMPP compatible with your version of MyBB?

What version of MyBB?

I am about to download MyBB and test it for you but I must know your versions.

Have you done a search for SQL error 1064 on the MyBB forums?

The assumption from MyBB forum is that you may not have imported your database correctly using phpMyAdmin.

Take a look at these Google search results

So my conclusion up to now is it is MyBB issue not a MySQL in XAMPP issue.

Have you tried to install MyBB again to see if you get the same error?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Installing MyBB... Error

Postby Sharley » 24. March 2011 10:57

Just found this post in their forums that seems to apply to an issue with MySQL 5.5.*
http://community.mybb.com/thread-87987-post-643126.html
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Installing MyBB... Error

Postby Altrea » 24. March 2011 12:17

The Syntax "TYPE" to define the storage engine was deprecated since MySQL 4.1 (!!!) and have been removed with MySQL 5.4.4 (never been released as stable).
Instead of TYPE you had to use ENGINE to define a MySQL Storage Engine.

Many old sql Import Scripts has to be refreshed for MySQL 5.5 compatibility.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Installing MyBB... Error

Postby Sharley » 24. March 2011 23:55

Sharley wrote:Just found this post in their forums that seems to apply to an issue with MySQL 5.5.*
http://community.mybb.com/thread-87987-post-643126.html
The solution is in this link for MyBB which released an updated file to correct the TYPE issue.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Installing MyBB... Error

Postby Rhineus » 26. March 2011 10:35

Hello all,

Yes, I have been looking at that Sharley and I've tried over an over and I still can't get it. I have MyBB 1.6.2 and I have XAMPP 1.7.5 Beta1 USB Lite (the latest) installed on the root of the drive. But just today I updated XP and for some reason Apache don't wont to connect. I got the error: "WARNING: terminating worker thread 0". I have EasyPHP on my computer and when I went to start its Apache, it said "Error in config file: ""This system cannot execute the specified program."" Edit?" And they both worked before I updated... I know that EasyPHP don't belong here but, that's what I did. But since that fix was made for MyBB 1.6.1, it doesn't work right. I read on other threads about this problem, and most of the people said check your apache\logs\error.log but mine don't have anything, just blank. I just have to get this thing with Apache not working before I go any where else.

Thank you,
Michael
Rhineus
 
Posts: 3
Joined: 28. November 2010 11:30

Re: Installing MyBB... Error

Postby Sharley » 26. March 2011 10:45

Find out what is using the ports that Apache in XAMPP uses - port 80 and port 443 also find out which of your MySQL installations is using port 3306.

XAMPP's components can't share these ports so find out where the conflict is, correct it and then start Apache and MySQL in the XAMPP Control Panel.

Download this little app that needs no installation, run the exe file before trying to start Apache and MySQL in XAMPP and it will tell your who is using the specific ports:
http://www.nirsoft.net/utils/cports.html

BTW no error log file means that Apache in XAMPP has never started as the log file is created automagically when Apache first starts and then makes an entry every time it starts and stops.

After the Windows update, check the security settings in particular the firewall and any anti-virus scanners have not been reset to block the server ports.

Also there is no support here for beta versions of XAMPP so please use the form on the beta home page if you have issues with 1.7.5 b1.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Installing MyBB... Error

Postby Rhineus » 26. March 2011 22:15

Hello Sharley,

LOL, Today Apache connected, and I didn't do nothing to it either... Weird lol But thank you for helping, now I got to ask in the MyBB support forum about the workaround issue for MyBB 1.6.2 :)
Rhineus
 
Posts: 3
Joined: 28. November 2010 11:30


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests