Xampp crashes internet & Windows

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp crashes internet & Windows

Postby proxikal » 22. March 2011 05:55

Hello, back a few years ago i used phperl on Windows XP, i just recently got back into coding and i wanted to use it or a program alike. my problem is i have tried phperl, wamp server, Xampp and a ton others. as soon as i open the program and start the apache, mysql my internet locks up completely. and i cannot use ctrl+alt+delete an error pops up.

i have experienced blue screen then a total shut down and no idea why.
i don't have skype installed. some have asked me that already

I'm running windows xp service pack 3 my computer specs should be more than enough to run this:
AMD Phenom(tm) II X2 550
3.11 GHz, 6gb ram
1.5 gb GeoForce

aDSL internet: 3.5mbps

hopefully someone can help me out this is crazy never had this happen before -_-'
proxikal
 
Posts: 5
Joined: 22. March 2011 05:51

Re: Xampp crashes internet & Windows

Postby Sharley » 22. March 2011 07:10

proxikal wrote:my problem is i have tried phperl, wamp server, Xampp and a ton others.
All these are web server suits and won't run together - only one at a time or else you will have port conflicts and who knows what else.
Check the \xampp\apache\logs\error.log file for clues.
What version of XAMPP?

proxikal wrote:as soon as i open the program and start the apache, mysql my internet locks up completely. and i cannot use ctrl+alt+delete an error pops up.
How are you trying to start Apache and MySQL in XAMPP and what error is that?

Make sure that you only run one of these servers at once and if using XAMPP and before starting anything check that the ports 80, 443 and 3306 are free and not in use by anything else.

Also check your Start>Administrative Tools>Event Viewer>Applications and or System for more clues why your PC locks up.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xampp crashes internet & Windows

Postby proxikal » 23. March 2011 00:28

its the newest version of xampp (XAMPP 1.7.4), i have only had one program installed at a time, what happens is my firefox gets some kinda Shell error and just won't open at all, and when i ctrl+alt+delete i get a refrence error.
in Wamp server i checked the error logs and i got nothing, blank files. i haven't yet checked the logs to xampp but i figured nothing would show there anyways

but its not a matter of apache not working, it simply Shuts my internet off 100%, And makes firefox completely broke along with my ctrl+alt delete

And all three suits do the exact same thing. i can install it again and see if i can record the errors i get, the last time this happen it blue screened me. something i haven't seen since windows 98, and once restarted my pc was making goofy noises. this pc is only 6 months old and maintained very well.

i just can't understand why this happens but let me try to record these errors and i'll post if xampp or wamp says anything in the error logs.
proxikal
 
Posts: 5
Joined: 22. March 2011 05:51

Re: Xampp crashes internet & Windows

Postby proxikal » 23. March 2011 01:01

Ok well i finally got Xampp running with mysql & apache... and now when i go to localhost it doesn't freeze my internet or anything
But i can't get localhost to bring anything up at all. just a constant loading. thanks for anyone who can help :)

this is what i got in the xampp error.log

Code: Select all
[Tue Mar 22 20:06:47 2011] [notice] Digest: generating secret for digest authentication ...
[Tue Mar 22 20:06:47 2011] [notice] Digest: done
[Tue Mar 22 20:06:48 2011] [notice] Child 3728: Child process is running
[Tue Mar 22 20:06:48 2011] [notice] Child 3728: Acquired the start mutex.
[Tue Mar 22 20:06:48 2011] [notice] Child 3728: Starting 150 worker threads.
[Tue Mar 22 20:06:48 2011] [notice] Child 3728: Listening on port 443.
[Tue Mar 22 20:06:48 2011] [notice] Child 3728: Listening on port 80.
[Tue Mar 22 20:06:48 2011] [error] (OS 10038)An operation was attempted on something that is not a socket.  : Too many errors in select loop. Child process exiting.
[Tue Mar 22 20:06:48 2011] [notice] Child 3728: Exit event signaled. Child process is ending.
[Tue Mar 22 20:06:49 2011] [notice] Child 3728: Released the start mutex
[Tue Mar 22 20:06:49 2011] [notice] Child 3728: All worker threads have exited.
[Tue Mar 22 20:06:49 2011] [notice] Child 3728: Child process is exiting
[Tue Mar 22 20:06:50 2011] [notice] Parent: child process exited with status 0 -- Restarting.
[Tue Mar 22 20:06:50 2011] [notice] Digest: generating secret for digest authentication ...
[Tue Mar 22 20:06:50 2011] [notice] Digest: done
[Tue Mar 22 20:06:52 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Mar 22 20:06:52 2011] [notice] Server built: Oct 18 2010 01:58:12
[Tue Mar 22 20:06:52 2011] [notice] Parent: Created child process 2248



Also i checked to make sure all ports was not in use 80,443 and that 3306 and i netstat -noa to preview
i got alot of this
Localhost 0.0.0.0:443 Foreign Address 0.0.0.0:443
Localhost 0.0.0.0:80 Foreign Address 0.0.0.0:80
Localhost 0.0.0.0:3306 Foreign Address 0.0.0.0:3306

was the top results. i don't know if this is an issue or what?
proxikal
 
Posts: 5
Joined: 22. March 2011 05:51

Re: Xampp crashes internet & Windows

Postby Sharley » 23. March 2011 01:33

Maybe a router port forward issue???

At the end of this post - try downloading Curr Ports as it may give more details about about the ports:
viewtopic.php?f=16&t=45235&p=176137

Check the httpd.conf file Listen directive is Listen 80 or Listen *:80 and not anything else.

At least you are not getting a bsod now. :)

You could try 1.7.3 version and see if it is any better for your needs:
viewtopic.php?p=176188#p176188
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xampp crashes internet & Windows

Postby proxikal » 23. March 2011 05:02

ok i uninstalled and wiped registry clean of xampp. i found an independant installer for apache called (httpd) now i am sure it was apache that crashed me not xampp or mysqld

Now here is the more specific problem since i am aware of more:
xampp or httpd(apache) itself doesn't crash windows or my internet what happens is if i try to visit http://localhost:80 it will continue to load. but if i leave it loading
for more than 3 minutes my internet literally shuts right down. i cannot even access my router address. And when i hit Control+alt+delete to figure out whats going on i get this error:

http://i51.tinypic.com/ax0bc0.jpg

its very confusing like i said i have used apache before many times with windows 98, 2000, and XP this is very weird.

i have called my ISP and they do alow webservers to be hosted off of port 80. and my router is westell and i added the ports accordingly to the manual of apache
and my router itself.

But i am not just trying to get it online. which is something i wanna do. but the first priority is just to get the localhost to load for me locally. its boggling my brain lol
i would really appreciate any help.

and for future questions; yes i check to make sure all ports are not being used by other programs, i have service pack 3 fully updated.
i do not have multiple webservers like (xampp, wamp server, phperl, httpd) at the same time all of these programs was tested individually
and it is confirmed its just Apache causing the problem :(
proxikal
 
Posts: 5
Joined: 22. March 2011 05:51

Re: Xampp crashes internet & Windows

Postby Sharley » 23. March 2011 05:27

With regard to your error message, before this error appears and during the 3 minute lull open the Task Manager>Processes tab and look for any process that may be using a high percentage of CPU - let me know if you find a high usage process.

This error may be induced by not having the correct and required Microsoft.NET Framework 1.1 - just download and install all available .net frameworks from here:
http://msdn.microsoft.com/en-us/netframework/aa569263
Specifically Microsoft.NET Framework versions 1.1 should be included in your download and install list not just simply the latest version as older versions are not included in the latest versions and 1.1 is required.

You may find the installed versions here:
C:\WINDOWS\Microsoft.NET\Framework
Should have at least 1.1, 2, 3, 3.5, 4 etc. in this folder.


Take a look at these Search Results that may also provide clues and solutions.


Good luck and do hope you can move forward soon. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 71 guests