End of my tether with apache.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

End of my tether with apache.

Postby Huwtrosky » 21. March 2011 23:18

Basically I have the same problem as everyone else port 80 not working blah blah blah. So here are the things I have done.
-Configured my router to port forward Apache on port 85
-Configured the firewall to allow inbound and outbound traffic from 85
-Configured the apache conf file to list to 127.0.0.1:85
-Identified that SOMETHING is running on port 80 put the PID 3897 doesn't show up on task list.

I cannot find any solution and it is driving me mad! Any suggestions?

Also here is the error log:

Code: Select all
[Sun Mar 20 18:39:46 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 20 18:39:46 2011] [notice] Digest: done
[Sun Mar 20 18:39:47 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Mar 20 18:39:47 2011] [notice] Server built: Oct 18 2010 01:58:12
[Sun Mar 20 18:39:47 2011] [notice] Parent: Created child process 7076
[Sun Mar 20 18:39:48 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 20 18:39:48 2011] [notice] Digest: done
[Sun Mar 20 18:39:49 2011] [notice] Child 7076: Child process is running
[Sun Mar 20 18:39:49 2011] [notice] Child 7076: Acquired the start mutex.
[Sun Mar 20 18:39:49 2011] [notice] Child 7076: Starting 150 worker threads.
[Sun Mar 20 18:39:49 2011] [notice] Child 7076: Starting thread to listen on port 443.
[Sun Mar 20 18:39:49 2011] [notice] Child 7076: Starting thread to listen on port 80.
[Sun Mar 20 18:59:46 2011] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Mar 20 18:59:46 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 20 18:59:46 2011] [notice] Digest: done
[Sun Mar 20 19:09:29 2011] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Mar 20 19:09:29 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 20 19:09:29 2011] [notice] Digest: done
[Sun Mar 20 19:09:30 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Mar 20 19:09:30 2011] [notice] Server built: Oct 18 2010 01:58:12
[Sun Mar 20 19:09:30 2011] [notice] Parent: Created child process 6944
[Sun Mar 20 19:09:31 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 20 19:09:31 2011] [notice] Digest: done
[Sun Mar 20 19:09:32 2011] [notice] Child 6944: Child process is running
[Sun Mar 20 19:09:32 2011] [notice] Child 6944: Acquired the start mutex.
[Sun Mar 20 19:09:32 2011] [notice] Child 6944: Starting 150 worker threads.
[Sun Mar 20 19:09:32 2011] [notice] Child 6944: Starting thread to listen on port 443.
[Sun Mar 20 19:09:32 2011] [notice] Child 6944: Starting thread to listen on port 80.
[Sun Mar 20 20:50:29 2011] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Mar 20 20:50:29 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 20 20:50:29 2011] [notice] Digest: done
[Sun Mar 20 20:50:30 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Mar 20 20:50:30 2011] [notice] Server built: Oct 18 2010 01:58:12
[Sun Mar 20 20:50:30 2011] [notice] Parent: Created child process 5316
[Sun Mar 20 20:50:31 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 20 20:50:31 2011] [notice] Digest: done
[Sun Mar 20 20:50:32 2011] [notice] Child 5316: Child process is running
[Sun Mar 20 20:50:32 2011] [notice] Child 5316: Acquired the start mutex.
[Sun Mar 20 20:50:32 2011] [notice] Child 5316: Starting 150 worker threads.
[Sun Mar 20 20:50:32 2011] [notice] Child 5316: Starting thread to listen on port 443.
[Sun Mar 20 20:50:32 2011] [notice] Child 5316: Starting thread to listen on port 80.
[Sun Mar 20 21:32:12 2011] [warn] (OS 64)The specified network name is no longer available.  : winnt_accept: Asynchronous AcceptEx failed.
[Sun Mar 20 21:35:18 2011] [error] [client 58.218.204.110] script 'C:/xampp/htdocs/judge.php' not found or unable to stat
Huwtrosky
 
Posts: 2
Joined: 21. March 2011 23:02

Re: End of my tether with apache.

Postby Sharley » 22. March 2011 01:01

First of all try and put everything back to the XAMPP installation defaults so we can see where you are having difficulties.

When you return your httpd.conf file back to the original make sure the line Listen reads:
Code: Select all
Listen 80
or
Listen *:80
If you use 127.0.0.1 then localhost will be the only method of accessing your server where as if you use either of the above then Apache will listen on any address using port 80.

Now the port 80 occupied issue, I take it you are using version 1.7.4 of XAMPP?

Go to start>Run... and type cmd.exe then cd C:\Windows
Next type netstat -ano |findstr "80"

Now check the PID using Task Manager - right click on the Task Bar and select Task Manager then the Processes tab - port 80 may be occupied by System, httpd.exe, apache.exe or other software using it like Skype and some others you may have installed.

From what I see you may have The Windows IIS - World Wide Publishing - default server still enabled so try this:
viewtopic.php?p=169028#p169028

Code: Select all
[Sun Mar 20 21:32:12 2011] [warn] (OS 64)The specified network name is no longer available.  : winnt_accept: Asynchronous AcceptEx failed.
[Sun Mar 20 21:35:18 2011] [error] [client 58.218.204.110] script 'C:/xampp/htdocs/judge.php' not found or unable to stat
These 2 may relate to your changing of the httpd.conf file and when ever you edit this file then you have to restart Apache.
OS 64 error help may be in these search results.

From your error.log file Apache is still trying to listen on port 80 and port 443 with no apparent errors from the server which would show up if there was a port conflict.


If the command line netstat is not helpful then you can download and run this nice little app CurrPorts - cports.exe, that requires no installation, to see what is using your ports and is the core app of XAMPP's own xampp-portcheck.exe that has been omitted in 1.7.4 due to a recently departed developer having some copyright code included in the exe file:
Download link near the bottom of the page.
http://www.nirsoft.net/utils/cports.html

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: End of my tether with apache.

Postby Huwtrosky » 22. March 2011 18:15

I found the services which were the problems but the hitch is that if I stop them it stops my internet D:. I can only see the solution of telling Apache to listen somewhere else. I'm going to uninstall XAMPP and install the 1.7.3 version which seems more stable.

EDIT: Issue seems resolved. DL'ed 1.7.3 zip version unzipped to C:\ ran setup batch file and went on control panel and apache works
Huwtrosky
 
Posts: 2
Joined: 21. March 2011 23:02


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests