Apache not working in Windows 7 32bit

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache not working in Windows 7 32bit

Postby dshafford » 21. March 2011 18:52

I have recently installed XAMPP on my Windows 7 computer. My SQL starts fine but Apache does not. I have run a port check and under port 80 is says SYSTEM. I have tried to do the fix where you change the listen port to 85 but that does not help. Any help would be most grateful.
Posts: 1
Joined: 21. March 2011 18:46

Re: Apache not working in Windows 7 32bit

Postby Sharley » 22. March 2011 01:08

Revert your httpd.conf file back to the default but make sure that line Listen 80 is used and not Listen

System usually means that IIS or World Wide Publishing is using the ports or some other Windows service related application.

Disable completely IIS and do the port check again and all should be free, then try and start Apache again:
User avatar
AF Moderator
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache not working in Windows 7 32bit

Postby DC80 » 22. March 2011 10:05


I had recently the same problem. Try to shutdown some services. My problem was the World Wide Web service which is used by IIS. Although you do not have to it installed for some reason this service is required.

This applies most for port 80 and 443 (Could not bind or similar ( error if you try to start xampp_start.exe).

I also encountered the same problem with port 443 ( This was caused by poorly configured VPN connections. After i removed "incoming connections" icon from my network connections the problem was solved.
Posts: 24
Joined: 11. March 2011 13:35
Operating System: Linux Mint 12 (lisa)

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 71 guests