Problem with xampp in windows XP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with xampp in windows XP

Postby vkalasa » 16. March 2011 05:34

Hello guys,

I have xampp 1.7.4 installed in windows7 64 bit and is working fine ,I can access the page by typing the ip address of the server form the other computer which has operating system windows xp, but the problem is the links in the page are not click able.it just opens the page that's it.Why this is happening? Please help me out in resolving this issue.

Regards,
vinay
Last edited by vkalasa on 16. March 2011 05:38, edited 1 time in total.
vkalasa
 
Posts: 3
Joined: 16. March 2011 05:22

Re: Problem with xampp in windows XP

Postby Sharley » 16. March 2011 05:38

Check the paths in your scripts web pages.

What happens when you try and access the XAMPP Welcome Demo page from the other computer?
http:// [your Win7 PC IP here] /xampp/index.php

See if there are any clues in the \xampp\apache\logs\error.log file.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Problem with xampp in windows XP

Postby vkalasa » 16. March 2011 07:30

hello Sharley,

Access forbidden!

New XAMPP Security Concept:

Access to the Requested directory is only available for the local network.

the setting can be configure in the file "httpd-xampp.conf"

i am getting this if i try to open ip/xampp ,

but i can open ip/mydirectory/index.php but the links are not clickable.

thanks and regards

vinay
vkalasa
 
Posts: 3
Joined: 16. March 2011 05:22

Re: Problem with xampp in windows XP

Postby Sharley » 16. March 2011 07:47

Hello Vinay,

OK, that error message is normal and is working as it should.



What I want to do is quickly see if the issue is with your paths in the index.php of your own file.

So open the \xampp\apache\conf\extra\httpd.conf file in your text editor and look for this section and change it by adding the IP you are using to access the ip/mydirectory/index.php file
#
# New XAMPP security concept
#
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
Order deny,allow
Deny from all
Allow from 127.0.0.0/8
Allow from add the ip here
ErrorDocument 403 /error/HTTP_XAMPP_FORBIDDEN.html.var
</LocationMatch>
Save the file and restart Apache.


Now try and access http://ip/xampp/index.php and tell me if any of the links work on the page.

Make sure that the links on your own page are not prefixed with localhost or 127.0.0.1 as they mean they will only be available for the PC that XAMPP is installed on.

What is the index.php related to, is it a CMS or WordPress etc?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Problem with xampp in windows XP

Postby vkalasa » 17. March 2011 05:50

hello Sharley,
Thanks for your Quick replies,I tried changing the httpd-xampp.conf file.My problem is I can access these pages by other machine with os as windows 7 on the network,but cant do the same with windows xp.And My index page is a simple php file.
I think I need to change the version of the xampp .
regards,
vinay
vkalasa
 
Posts: 3
Joined: 16. March 2011 05:22


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests