Xampp 1.7.3 + Drupal 6.20 + W7 / WXP SP3

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp 1.7.3 + Drupal 6.20 + W7 / WXP SP3

Postby lobbytron » 14. March 2011 20:17

Hello,

I'm working on Windows Seven, and Xampp 1.7.3

Xampp is installed in the directory "d: \ xampp".

I develop two sites on Drupal 6.20Fr. They are installed in a directory "d: \ xampp \ site1" and "d: \ xampp \ site2" and 2 MySQL databases are created "site1" and "site2".

When I run "http://localhost/site1" or "http://localhost/site2, this works very well, and after the authentication phase of my homepage, I have access to all pages.

My problem is the transfer of my sites on another machine.

I export my 2 bases "site1.sql.zip" and "site2.sql.zip," and I copy the files with "site1" and "site2" on my USB stick.

My second machine is WXP SP3, Xampp 1.7.3. Xampp is installed in the directory "d: \ xampp".

In MySql, the two bases "site1" and "site2", and the same user with the same privileges are created.

I import the basic "site1.sql.zip" and I have no error. I import the basic "site2.sql.zip" and I have no error.

I copied the 2 files "site1" and "site2" under "d: \ xampp".

When I run "http://localhost/site1" or "http://localhost/site2" I manage fine on my home page for 2 sites.

However, once authenticated, the system automatically sends me on the home page of local Xampp.

Why does this work it very well on the first post, and not the second?

Have you any idea? Is this a problem with the ". Htaccess? Is this a problem with my "settings.php" Drupal sites?

Could you help me, I must make a presentation of the sites last week, and I can not find my mistake.

Thank you in advance
lobbytron
 
Posts: 2
Joined: 14. March 2011 20:09

Re: Xampp 1.7.3 + Drupal 6.20 + W7 / WXP SP3

Postby Sharley » 14. March 2011 22:36

Could be a .htaccess file but more likely the index.php in the htdocs folder is redirecting you to the index.php in the htdocs\xampp folder.

Try and rename the index.php in the htdocs folder to index.php_old or similar, alternatively delete the 2 index files for XAMPP in the htdocs folder.

You can still access the XAMPP demo pages by typing http://localhost/xampp in your browser.

Also make sure that if your paths have a slash at the beginning that the site1 and site2 folder follows this slash, for example:
\site1\index.php
\site2\index.php
Which is interpreted by Apache to look in the htdocs folder for a folder site1 and an index.php file or htdocs site2 folder with an index.php file.

If the path just has, for example:
\index.php
then Apache will look for the index.php file in the htdocs folder - the slash being interpreted as the DocumentRoot folder, htdocs.

If you rename or delete the 2 index files of XAMPP in the htdocs folder then you may get a 404 file not found error because of the incorrect paths in your scripts.

Best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xampp 1.7.3 + Drupal 6.20 + W7 / WXP SP3

Postby lobbytron » 16. March 2011 20:16

Thank you ...
lobbytron
 
Posts: 2
Joined: 14. March 2011 20:09


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 35 guests