Not Connecting

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Not Connecting

Postby m_i4 » 12. March 2011 00:10

So I went to the htdocs folder and edited the index thing and went to http//localhost/ and I saw my edited site. But whenever I try to connect to my IP address, it says it is taking too long to respond! I turned off firewall and gave my router permission to do it, but still nothing!

I used start port 80 and end port 81 for forwarding and the other thing, it still does not work. Why is this happening? aaa
m_i4
 
Posts: 3
Joined: 12. March 2011 00:07

Re: Not Connecting

Postby Sharley » 12. March 2011 01:22

I believe you can't access using your WAN (ISP) IP from within your LAN but others can from the Internet - not even sure if there is a work around either.

There are some posts on this subject but not sure of the link addresses for you - perhaps if you could do an advance search in the XAMPP for Windows English forum you may find them yourself.

Good luck and best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Not Connecting

Postby m_i4 » 12. March 2011 01:32

I am using WLAN, so you are saying I cannot connect to it? Why not? I have already tried searching and found nothing useful.

What ports do I need? What's wrong?
m_i4
 
Posts: 3
Joined: 12. March 2011 00:07

Re: Not Connecting

Postby Sharley » 12. March 2011 04:29

m_i4 wrote:it says it is taking too long to respond!
What's "it"?
What's the exact error message?


m_i4 wrote:I have already tried searching and found nothing useful
This issue is not an XAMPP specific issue but rather your router and is how most routers work.
It is related to whether or not your particular router can configure NAT loopback - you may be able to turn it on in your router settings.

http://opensimulator.org/wiki/NAT_Loopback_Routers
Many DSL routers/modems prevent loopback connections as a security feature. This means that a machine on your local network (e.g. behind your DSL router/modem) cannot connect to a forward facing IP address (such as 199.149.252.44) of a machine that it also on your local network. Connecting to the local IP address (such as 192.168.2.40) of that same machine works fine.
These Search Results may help.

Some other links to confirm that this is the behavior of most routers not individual web server related.
viewtopic.php?f=16&t=44842
viewtopic.php?f=16&t=43947

Use WAN and LAN IPs to Access Server Internal

LAN users connecting through WAN IP

NAT Loopback or Local Loopback
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Not Connecting

Postby m_i4 » 12. March 2011 12:18

Never mind, I found out that I needed to use an IP from ipconfig not WhatsMyIp.com, thanks anyways.
m_i4
 
Posts: 3
Joined: 12. March 2011 00:07


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests