Mysql table create/drop error ?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mysql table create/drop error ?

Postby Bancai » 11. March 2011 18:12

Hi again,


I've encountered another problem,this time with mysql (i'm using xampp 1.6.4), whenever i create something in SQL, i get the thing in the image bellow + when i drop a table it still does that. Any ideas what to do ?

Image
Bancai
 
Posts: 6
Joined: 11. March 2011 01:13

Re: Mysql table create/drop error ?

Postby Sharley » 11. March 2011 20:16

You need to look in the log files first to see if there are any clues:
\xampp\mysql\data\mysql.err
\xampp\mysql\data\[yourloginname].err
\xampp\apache\logs\error.log

This may be related to the libmysql.dll issue you had in your other topic here:
viewtopic.php?f=16&t=45023.

You could try replacing all those 5 dlls you found with the new one you download or at least the one in the \xampp\mysql\bin folder, but first rename the old ones so you can fall back if it was not a success.

Restart Apache and MySQL after you replace the dlls.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Mysql table create/drop error ?

Postby Bancai » 12. March 2011 00:12

Sharley wrote:You need to look in the log files first to see if there are any clues:
\xampp\mysql\data\mysql.err
\xampp\mysql\data\[yourloginname].err
\xampp\apache\logs\error.log

This may be related to the libmysql.dll issue you had in your other topic here:
viewtopic.php?f=16&t=45023.

You could try replacing all those 5 dlls you found with the new one you download or at least the one in the \xampp\mysql\bin folder, but first rename the old ones so you can fall back if it was not a success.

Restart Apache and MySQL after you replace the dlls.

Good luck.


No luck yet,i replaced the 5 dlls and still no improvement.I cant find any mysql.err file, and the [yourloginname].err file and error.log file don't show any errors for today's date or the hour it occurs.

any other suggestions ?
Bancai
 
Posts: 6
Joined: 11. March 2011 01:13

Re: Mysql table create/drop error ?

Postby Sharley » 12. March 2011 01:16

Without knowing all the settings you have made/changed during your tutorial it will be difficult for me to try and locate what is causing this.

Look in the Windows Event Viewer under Applications and see if there are any clues.

After you changed the dlls you did restart Apache and MySQL?

I can't reproduce this for you because I don't have 1.6.4 (I have 1.6.3a though) or the tutorial.

If you like, try another version like 1.6.8 which is what I am using and found it to be very stable - this would still work fine for your Tutorial.

I never use the Installer exe versions of XAMPP ever, only the 7zip archive versions as I believe this eliminates most of the issues associated with the Installer trying to cope with so many different PC configurations.

Also temporarily disable things like ZoneAlarm as well as any anti-virus background scanners if you have them running - if there is no change to the behavior then simply enable them again.

Sorry I can't be of more help on this one until I hear back if any of the above produces any more clues for us to work with.

Best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Mysql table create/drop error ?

Postby Bancai » 12. March 2011 15:35

Indeed it works better with 1.6.8 . no errors till now. 10q very much sir.


LE : So to not make another thread cuz that be spamming...

I get this error on the main page: Fatal error: Call to undefined method Catalog::getdepartmentdetails() in C:\tshirtshop\presentation\department.php on line 28

tho i did create the procedure:
Code: Select all
-- Create catalog_get_department_details stored procedure
CREATE PROCEDURE catalog_get_department_details(IN inDepartmentId INT)
BEGIN
  SELECT name, description
  FROM   department
  WHERE  department_id = inDepartmentId;
END$$


What could be the problem ?


LE2: i fixed it :P i had to keep reading instead of jumping pages like crazy
Bancai
 
Posts: 6
Joined: 11. March 2011 01:13


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests