os 10013 error please help.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

os 10013 error please help.

Postby DC80 » 11. March 2011 14:42

Hi all,

I have a problem starting xampp. It does start normal (xampp control panel), i can start MySQL normal but apache does not start. When i start xampp_start.exe (starting xampp without xampp control panel) i get this error:

os 10013 an attempt was made to access a socket in a way forbidden by its access permissions

To solve this problem i googled quite a while but i came up empty. I did find some topics that may seem the correct answer but after trying them it still wouldn't start.

After some search work i tried some system settings and checked out some programs from which is known they are using port 80 (and in the beginning port 443). I've used several programs like Team Viewer, Logmein and so on. I did uninstall them and rebooted my system. I also tried uninstall xampp and then reinstall it. This came up empty as it would not start. I keep getting the same message.

I do not use the following programs (these programs were never installed anyway because i have no use for them):
- Skype

Uninstalled programs (which are known to be using either port 80 of 443):
- LogmeIn
- Google Earth (just want te get rid of it)

Used (network)programs that I use:
- Remote desktop connection manager
- Remote desktop

I do not believe this is a problem because it is using RDP for protocol not http(s), also it is using port 3389 instead of 80 or 443.

After executing the netstat -o command on the CLI of windows it came up empty. Also the parameters -a and -b came up empty. However i did saw a process with (P)ID 4 using port 80 (something like this). This is a system process which i cannot kill.

The strange thing is that the installation of xampp (under portable apps) on my external hard drive (Western Digital Passport Essentials SE) is working fine. Also this problem is occurring since I updated my computer from microsoft (patch tuesday last week). Before this day it was working fine.

In order to be sure, i have had my firewall (which asked me permission when i installed xampp for the first time) and anti-virus scanner disabled. This did not work either. The firewall rule still exists anyway. I also cleaned my register. I found one entry which i removed after uninstalling xampp. I did install xampp more then once both with and without service. It still didn't work.

Please can someone help me?

Thanks in advance and kind regards,

Posts: 24
Joined: 11. March 2011 13:35
Operating System: Linux Mint 12 (lisa)

Re: os 10013 error please help.

Postby DC80 » 11. March 2011 15:56

Hi all,

I did some search work on the PID 4 system on port 80. After a while i found a forum with this problem discription (or similar) of port 80 being used by the system.
This turned out to be the problem. If you do not have IIS installed there are still some services (WWW service) that wants to be managed. This is probably done by the system. So this may be an solution for more users of XAMPP. Let me tell you how i've done it.

Step 1: go to the start menu and type services.msc (NOTE: this part of windows is to be executed as an administrator!) OR go to the XAMPP control panel and click "SCM...".

Step 2: Click on the first service you see and then type the W on your keyboard. Under the W look for World Wide Web Publishing service.

Step 3: Click on it with the right mouse button and choose stop service. (NOTE: The next time you start your computer it will be started again so the advice is to disable it instead unless you need the service. This can be done the same way only this time you need to choose properties.

Kind regards,

Posts: 24
Joined: 11. March 2011 13:35
Operating System: Linux Mint 12 (lisa)

Re: os 10013 error please help.

Postby epicStudio » 20. July 2011 09:43

@ DC80: I had the same problem, but now it works fine. Thank you for this great solution! :D
Posts: 1
Joined: 20. July 2011 09:40

Re: os 10013 error please help.

Postby DandyMan » 22. July 2011 03:18

Thanks, DC80. I've been all over the web looking for a solution to this and you found it! Many thanks.
Posts: 1
Joined: 22. July 2011 03:16

Re: os 10013 error please help.

Postby petralian » 01. September 2011 05:24

I am running windows 2008 R2 and the issue was in a service called: Routing and Remote Access
I stopped the service, then I could start XAMPP and then started the service again for vpn and such to work.

Another solution for me was to put Apache in Svc (service) mode...
reason for that is because those port occupying services (like Routing and Remote Access) usually use a delayed start, (you can check that in the services window, startup type column whether it uses "Automatic (delayed start)") so XAMPP will start before this service when using Apache as Svc.
Posts: 2
Joined: 28. February 2009 06:46

Re: os 10013 error please help.

Postby vmaslim » 10. September 2011 17:12

o.O seriously... xampp installer made me crazy this whole day...

i used to install xampp at windows xp n it run well.

now i installed xampp in win 7, xampp version 1.7.4 but it didn't run well cuz' it can't find its installed dir.
so, i installed the older version, 1.6.7. the mysql can start its service but apache can't. i googled the solutions, they say i must changed the port from 80 to 8080 or whatever. i did change it.. but nothing happend. i still found the OS10013.

so, i tried DC80 suggestion, i search World Wide Web Publishing service from SCM, but i didn't find it.
i try the solution from petralian. to stop Routing and Remote Access service.. but it stoped already before i did it..

o.O btw, i user win 7 home basic. is it the problem?? help please. many thanks ^.^~
Posts: 1
Joined: 10. September 2011 16:45

Re: os 10013 error please help.

Postby cfranz » 20. October 2011 18:54

You may also wish to look around for anything from the "Web Deployment Agent" or any other piece of Visual Studio 2010.
Posts: 1
Joined: 20. October 2011 18:04
Operating System: Windows 7

Re: os 10013 error please help.

Postby format997 » 07. February 2012 00:40

Stopping the web deployment agent service fixed it for me. Strange, as I don't believe that service actually uses port 80. But just posting this in case it helps anyone else.
Posts: 1
Joined: 07. February 2012 00:39
Operating System: Windows 7

Re: os 10013 error please help.

Postby nine05 » 30. March 2012 21:14


I try all the above solution but none of them works for me. But luckily I check all SQL SERVER 2008 Services and stop them one by one and I found out the SQL Server Reporting Services (MSSQLSERVER) is using port 80. I hope this will help you thanks :D
Posts: 1
Joined: 30. March 2012 21:05
Operating System: Windows 7

Re: os 10013 error please help.

Postby emitra123 » 03. June 2012 12:17

This stopping SSRS service works for me as well.

Thanks dude.

Posts: 1
Joined: 03. June 2012 12:14
Operating System: win 7

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests