MySQL Problem, 1.7.4 - Windows 7.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL Problem, 1.7.4 - Windows 7.

Postby Nublet » 06. March 2011 22:53

Hello, i downloaded the .zip file of xampp 1.7.4. Im using windows 7.

Apache started, was all fine, and when i started MySQL it said that it was started, and it continues to display as if it was started, HOWEVER when i got to http://localhost/security/ it says that MySQL is either not started, or blocked by a Firewall. I have disabled all my firewalls, so that cant be it.
oh, and when i start xampp control pannel it says: No installer package found, dunno if that has anything to do with it.

Ive spent hours trying to fix this. And this problem only occours on this computer which is running windows 7, on my laptop which runs windows xp it works fine.

What should i do to get MySQL running?
Nublet
 
Posts: 1
Joined: 06. March 2011 22:45

Re: MySQL Problem, 1.7.4 - Windows 7.

Postby Sharley » 07. March 2011 02:54

Try and remove the tick in the Svc check box in the XAMPP Control Panel.

Or run the \xampp\mysql\mysql_uninstallservice.bat bat file.

Try again to start MySQL.


Most issues with 1.7.4 have been recorded in this topic on the forums:
viewtopic.php?f=16&t=44327

One solution that seems to work to fix most common issues is to do a clean uninstall of the exe installer version of 1.7.4.
You may find some tips for uninstalling here:
viewtopic.php?p=175157#p175157

Then download and unpack the zip version to your C:\ drive or the root folder of any drive or partition, then to complete this method simply run the setup_xampp.bat file found in the \xampp\ folder, which will set the paths and configure the installation for you.

Make sure that you don't have another MySQL installation loading when you boot your computer - check Windows Task Manager for mysqld.exe in the Processes tab - kill it if you find one and then try and locate why it is being loaded on boot.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests