cannot make firebird extension work!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

cannot make firebird extension work!

Postby jacobswell » 03. March 2011 07:18

First, I found there disappeared firebird/interbase extension files in ext folder, so I copied from 1.7.3.

I have no problem with Xampp server installed in C drive. Whenever I started the Xampp server with firebird installed as a service, it works giving no error messages.

But I have another portable virtual xampp server in my usb hdd using "subst" DOS command.
The old version 1.7.3 have been working perfectly.

I made a portable server with 1.7.4 and it gives error because it cannot load the php_interbase.dll and php_pdo_firebird.dll and I cannot find why.

I have tried with dll file from firebird yahoo group and still see the error message.

Is there any person who have succeeded with firebird extension? Please tell me your know-how. :-)
jacobswell
 
Posts: 2
Joined: 03. February 2005 04:25

Re: cannot make firebird extension work!

Postby jacobswell » 05. March 2011 06:22

solved!

The problem is in fbclient.dll. the snapshot firebird dll has a problem so I had to copy from the 2.5 released version.

Also I found the libmysql.dll has a problem with mysqli. it can be solved using with older version of libmysql.dll from xampp 1.7.3. The location is /xampp/php. :-)
jacobswell
 
Posts: 2
Joined: 03. February 2005 04:25


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests