Maximum execution time of 60 seconds exceeded .---- where *

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Maximum execution time of 60 seconds exceeded .---- where *

Postby garfy » 27. February 2011 19:53

I got this error after installing module in drupal, I am using xampp

Fatal error: Maximum execution time of 60 seconds exceeded in D:\XAMPP\xampp\htdocs\drupal6\includes\common.inc on line 552

I cant find php,ini, where is this file, do i have to drop it in the drupal directory?

Where is the php.ini file, I cant find it anywhere????
garfy
 
Posts: 36
Joined: 14. January 2011 08:32

Re: Maximum execution time of 60 seconds exceeded .---- wher

Postby kraig » 27. February 2011 20:13

Not sure if you have to put it in the drupal directory, but for the php.ini file:

"Since XAMPP 1.7.1 the "php.ini" is only in the directory "\xampp\php". Till XAMPP 1.7.0 is was in the directory "\xampp\apache\bin".

If a change in the "php.ini" have no effect, it's possible PHP is still using an other one. You can verify this with phpinfo(). Go to the URI http://localhost/xampp/phpinfo.php and search for "Loaded Configuration File". This value shows you the "php.ini" PHP is really using.
"
kraig
 
Posts: 3
Joined: 27. February 2011 19:24

Re: Maximum execution time of 60 seconds exceeded .---- wher

Postby kraig » 27. February 2011 20:17

Also, check out this forum, it may have your answer: http://groups.drupal.org/node/120809
kraig
 
Posts: 3
Joined: 27. February 2011 19:24

Re: Maximum execution time of 60 seconds exceeded .---- wher

Postby garfy » 27. February 2011 21:23

thank you for that, i found php file

I set the execution time to 360 sec

but still i get errors when try to import data into drupal

here are errors, is this because of xampp?

I buffered many specs in my.ini file too, like drupal recommends, but still I get these errors

Code: Select all
An error occurred. /drupal6/batch?id=8&op=do <br /> <b>Warning</b>: MySQL server has gone away query: INSERT INTO watchdog (uid, type, message, variables, severity, link, location, referer, hostname, timestamp) VALUES (1, &#039;php&#039;, &#039;%message in %file on line %line.&#039;, &#039;a:4:{s:6:\&quot;%error\&quot;;s:12:\&quot;user warning\&quot;;s:8:\&quot;%message\&quot;;s:0:\&quot;\&quot;;s:5:\&quot;%file\&quot;;s:49:\&quot;D:\\XAMPP\\xampp\\htdocs\\drupal6\\includes\\common.inc\&quot;;s:5:\&quot;%line\&quot;;i:3538;}&#039;, 3, &#039;&#039;, &#039;http://localhost/drupal6/batch?id=8&amp;op=do&#039;, &#039;http://localhost/drupal6/batch?op=start&amp;id=8&#039;, &#039;127.0.0.1&#039;, 1298838067) in <b>D:\XAMPP\xampp\htdocs\drupal6\includes\database.mysqli.inc</b> on line <b>135</b><br /> <br /> <b>Warning</b>: MySQL server has gone away query: INSERT INTO watchdog (uid, type, message, variables, severity, link, location, referer, hostname, timestamp) VALUES (1, &#039;php&#039;, &#039;%message in %file on line %line.&#039;, &#039;a:4:{s:6:\&quot;%error\&quot;;s:7:\&quot;warning\&quot;;s:8:\&quot;%message\&quot;;s:141:\&quot;Cannot modify header information - headers already sent by (output started at D:\\XAMPP\\xampp\\htdocs\\drupal6\\includes\\database.mysqli.inc:135)\&quot;;s:5:\&quot;%file\&quot;;s:49:\&quot;D:\\XAMPP\\xampp\\htdocs\\drupal6\\includes\\common.inc\&quot;;s:5:\&quot;%line\&quot;;i:148;}&#039;, 3, &#039;&#039;, &#039;http://localhost/drupal6/batch?id=8&amp;op=do&#039;, &#039;http://localhost/drupal6/batch?op=start&amp;id=8&#039;, &#039;127.0.0.1&#039;, 1298838068) in <b>D:\XAMPP\xampp\htdocs\drupal6\includes\database.mysqli.inc</b> on line <b>135</b><br /> { "status": true, "percentage": 16, "message": "\x3cbr/\x3e\x26nbsp" }<br /> <b>Warning</b>: MySQL server has gone away query: INSERT INTO watchdog (uid, type, message, variables, severity, link, location, referer, hostname, timestamp) VALUES (1, &#039;php&#039;, &#039;%message in %file on line %line.&#039;, &#039;a:4:{s:6:\&quot;%error\&quot;;s:12:\&quot;user warning\&quot;;s:8:\&quot;%message\&quot;;s:641:\&quot;MySQL server has gone away\nquery: UPDATE sessions SET uid = 1, cache = 0, hostname = &amp;#039;127.0.0.1&amp;#039;, session = &amp;#039;node_overview_filter|a:0:{}messages|a:1:{s:5:\\&amp;quot;error\\&amp;quot;;a:2:{i:0;s:81:\\&amp;quot;user warning: in D:\\\\XAMPP\\\\xampp\\\\htdocs\\\\drupal6\\\\includes\\\\common.inc on line 3538.\\&amp;quot;;i:1;s:216:\\&amp;quot;warning: Cannot modify header information - headers already sent by (output started at D:\\\\XAMPP\\\\xampp\\\\htdocs\\\\drupal6\\\\includes\\\\database.mysqli.inc:135) in D:\\\\XAMPP\\\\xampp\\\\htdocs\\\\drupal6\\\\includes\\\\common.inc on line 148.\\&amp;quot;;}}&amp;#039;, timestamp = 1298838068 WHERE sid = & in <b>D:\XAMPP\xampp\htdocs\drupal6\includes\database.mysqli.inc</b> on line <b>135</b><br /> <br /> <b>Warning</b>: MySQL server has gone away query: INSERT INTO watchdog (uid, type, message, variables, severity, link, location, referer, hostname, timestamp) VALUES (1, &#039;php&#039;, &#039;%message in %file on line %line.&#039;, &#039;a:4:{s:6:\&quot;%error\&quot;;s:12:\&quot;user warning\&quot;;s:8:\&quot;%message\&quot;;s:22114:\&quot;MySQL server has gone away\nquery: UPDATE batch SET batch = &amp;#039;a:10:{s:4:\\&amp;quot;sets\\&amp;quot;;a:1:{i:0;a:9:{s:7:\\&amp;quot;sandbox\\&amp;quot;;a:0:{}s:7:\\&amp;quot;results\\&amp;quot;;a:0:{}s:7:\\&amp;quot;success\\&amp;quot;;b:0;s:5:\\&amp;quot;title\\&amp;quot;;s:9:\\&amp;quot;Importing\\&amp;quot;;s:10:\\&amp;quot;operations\\&amp;quot;;a:1:{i:0;a:2:{i:0;s:11:\\&amp;quot;feeds_batch\\&amp;quot;;i:1;a:3:{i:0;s:6:\\&amp;quot;import\\&amp;quot;;i:1;s:15:\\&amp;quot;csv_reno_import\\&amp;quot;;i:2;i:0;}}}s:16:\\&amp;quot;progress_message\\&amp;quot;;s:0:\\&amp;quot;\\&amp;quot;;s:12:\\&amp;quot;init_message\\&amp;quot;;s:24:\\&amp;quot;Initializing.&amp;lt;br/& in <b>D:\XAMPP\xampp\htdocs\drupal6\includes\database.mysqli.inc</b> on line <b>135</b><br />
garfy
 
Posts: 36
Joined: 14. January 2011 08:32

Re: Maximum execution time of 60 seconds exceeded .---- wher

Postby garfy » 28. February 2011 06:25

any help?
garfy
 
Posts: 36
Joined: 14. January 2011 08:32

Re: Maximum execution time of 60 seconds exceeded .---- wher

Postby Altrea » 28. February 2011 06:34

You should be patient.

This is a non profit board. All helpers here are helping in their freetime and can't be online 24/7.
Maybe it will take a day or two. You can bump your post again, if you don't get an answer in a couple of days, but not in a couple of hours.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Maximum execution time of 60 seconds exceeded .---- wher

Postby eddie007bkk » 20. March 2011 14:14

I had the same problem and fixed by adding the following below in sites\default\settings.php, more detail at http://drupal.org/node/454372

ini_set('max_execution_time', 300);

Normally the settings.php is READ ONLY file, so you have to change its attribute. I changed to 60, and still got the error. Then tried at 300, and working ...
eddie007bkk
 
Posts: 1
Joined: 20. March 2011 14:03


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 80 guests