New XAMPP Install Phpmyadmin error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

New XAMPP Install Phpmyadmin error

Postby ataylor20 » 15. February 2011 15:14

Error message when trying to go to :
http://localhost/phpmyadmin/
Image

After trying version 1.7.4 I figured it might be a bug so I downloaded 1.7.3 and im still having this issue. I did a couple of searches and dont see this as a typical after install issue. I have changed no settings only installed the software.

Help!

Thanks in advance.

-Drew
ataylor20
 
Posts: 1
Joined: 15. February 2011 14:45

Re: New XAMPP Install Phpmyadmin error

Postby Altrea » 15. February 2011 16:28

- fully uninstall xampp (unregister services + close all xampp processes + delete the whole xampp folder)
- download a new installer or zip version from apachefriends.org
- "install"/extract the new files directly in your root folder of your partition
- (execute setup_xampp.bat file if you use the zip version, the installer will start it automatically)
- start xampp control panel
- start Apache and MySQL in the control panel (leave the svc checkboxes untouched)
- try phpmyadmin again.

Good luck
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: New XAMPP Install Phpmyadmin error

Postby Mags » 20. February 2011 16:47

I also have a new XAMPP install and am experiencing the same error.

Initial install was using the .exe install, but couldn't access localhost. I followed the info in another topic and completely uninstalled the .exe install using Revo uninstaller. Then ran a registry checker to see if anything was left over but couldn't find anything. Did a reinstall using the 7zip download then I could access the local host.

Now I can't access phpmyadmin. The msg I get is #2002 - The server is not responding (or the local MySLQ server's socket is not correctly configured) Next to the info icon is the msg Connection for controluser as defined in your configuration failed. In the xampp control panel it shows both Apache and MySLQ as running (Scv boxes are not checked. When I open localhost and click on status, it shows MySLQ database as deactivated.

I've checked the forum to see if there was any topic similar to my problem but couldn't find anything. The only info that I thought would help was on this page http://www.apachefriends.org/en/xampp-windows.html and that was to run xampp_start.exe but that didn't do anything.

I then googled for info and couldn't find anything current, just outdated info. Since what I was finding was outdated info and I didn't want to attempt trying anything as it could make the problem worse, I'm now back here to see if this can be resolved.
Mags
 
Posts: 2
Joined: 18. February 2011 19:06

Re: New XAMPP Install Phpmyadmin error

Postby Podjigateli » 18. March 2011 15:46

Maybe you have old Mysql installation in your PC. Uninstall all MYsql programs and all xampp from your pc and reinstall Xampp.
Podjigateli
 
Posts: 1
Joined: 18. March 2011 15:40

Re: New XAMPP Install Phpmyadmin error

Postby dlpenguinlover » 20. March 2011 18:17

Mags wrote:I also have a new XAMPP install and am experiencing the same error.

Initial install was using the .exe install, but couldn't access localhost. I followed the info in another topic and completely uninstalled the .exe install using Revo uninstaller. Then ran a registry checker to see if anything was left over but couldn't find anything. Did a reinstall using the 7zip download then I could access the local host.

Now I can't access phpmyadmin. The msg I get is #2002 - The server is not responding (or the local MySLQ server's socket is not correctly configured) Next to the info icon is the msg Connection for controluser as defined in your configuration failed. In the xampp control panel it shows both Apache and MySLQ as running (Scv boxes are not checked. When I open localhost and click on status, it shows MySLQ database as deactivated.

I've checked the forum to see if there was any topic similar to my problem but couldn't find anything. The only info that I thought would help was on this page http://www.apachefriends.org/en/xampp-windows.html and that was to run xampp_start.exe but that didn't do anything.

I then googled for info and couldn't find anything current, just outdated info. Since what I was finding was outdated info and I didn't want to attempt trying anything as it could make the problem worse, I'm now back here to see if this can be resolved.


Hello, I have gotten this error on a brand new computer that has never had xampp, mysql, or anything before. I am runnign Windows XP SP3.
dlpenguinlover
 
Posts: 4
Joined: 22. August 2010 05:23

Re: New XAMPP Install Phpmyadmin error

Postby mjstelly » 14. June 2011 19:08

I fixed this error by commenting out the following configuration in /xampp/phpMyAdmin/config.inc.php

/* User for advanced features */
// $cfg['Servers'][$i]['controluser'] = 'pma';
// $cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
// $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
// $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
// $cfg['Servers'][$i]['relation'] = 'pma_relation';
// $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
// $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
// $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
// $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
// $cfg['Servers'][$i]['history'] = 'pma_history';
// $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

I restarted apache and mysql, then tried again. Success! :D
mjstelly
 
Posts: 1
Joined: 14. June 2011 19:04

Re: New XAMPP Install Phpmyadmin error

Postby Altrea » 14. June 2011 21:30

Thats no fix.
Now you have reduced the magical phpMyAdmin tool to a small programm for listing mysql database tables.
All the cool information and administration stuff about your database is unusable.

Why don't you just delete your phpMyAdmin folder and it's database? That has nearly the same effect :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: New XAMPP Install Phpmyadmin error

Postby samik666 » 22. June 2011 10:30

Hey there, I am having trouble with my XAMPP install also, same problem.
I'm trying to learn SQL and am doing a tutorial which uses XAMPP for the examples.

I am running XAMPP 1.7.4 and the error I am getting is the same:
Image
Is it possibly an OS related problem? My PC stats are as follows:
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110408-1631)
System Manufacturer: Hewlett-Packard
System Model: HP Pavilion dv7 Notebook PC
Processor: AMD Phenom(tm) II N620 Dual-Core Processor (2 CPUs), ~2.8GHz
Memory: 4096MB DDR3 RAM

Please help, I am seriously baffled, I've un-installed XAMPP, deleted all the directories, un-installed MySQL and anything else on my PC that had SQL in the name lol.. What can I do?
Any help will be much appreciated!
Sam.
samik666
 
Posts: 3
Joined: 22. June 2011 09:24

Re: New XAMPP Install Phpmyadmin error

Postby Altrea » 22. June 2011 10:54

have you changed the password for the root user(s)?
http://drupal.org/node/462582
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: New XAMPP Install Phpmyadmin error

Postby samik666 » 22. June 2011 11:25

Okay, excuse my idiocy.. I restarted my computer and bang, fizz.. It all works as it should.. Perhaps I should have tried that before posting..

Appologies, and thanks very much for your prompt assistance!
Sam.
samik666
 
Posts: 3
Joined: 22. June 2011 09:24


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 78 guests