Setup of XAMPP and Microsoft IIS

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Setup of XAMPP and Microsoft IIS

Postby robert99 » 12. February 2011 15:07

Windows Vista SP2
XAMPP 1.7.4 installed in C:\xampp on stand alone computer
IIS 7 (needed for Visual Studio programs)
IE8 etc


Hello,

I am new to XAMPP as well as servers and after installation have also found that Microsoft web server IIS has taken over http:/localhost as well as port 80.

Apache cannot start as port80 is "busy" (presumably IIS has taken it over)

http://localhost /xampp cannot find the XAMPP demo page as IIS causes it to look in the C:\inetpub\wwwroot folder instead of somewhere in C:\xampp

There are some Googled links below that give some info on a fix to run XAMPP as well as IIS, but which is the best way (XAMPP will be main useage)?

Can someone take me through the necessary changes in simple steps for XAMPP 1.7.4 to run with IIS installed ?


http://varunkrish.com/making-apachexamp ... ether.html

http://one7.wordpress.com/2009/04/28/us ... -solution/

http://blog.wolffmyren.com/2008/07/30/m ... s-xpvista/

Thank you
robert99
 
Posts: 6
Joined: 28. January 2010 21:08

Re: Setup of XAMPP and Microsoft IIS

Postby peterwt » 13. February 2011 17:25

Hi robert99,

I had Apache and MS IIS on my last PC under Vista.

IIS runs as a servive set to autostart. The simplest way is to set IIS to manual start and only run it when you need it for visual studio. if you are running XAMPP Apache as a service stop it before you run IIS service.

Peter
Peter
peterwt
 
Posts: 42
Joined: 17. March 2009 11:06
Operating System: Windows 7 64 bit Professional

Re: Setup of XAMPP and Microsoft IIS

Postby robert99 » 15. February 2011 15:40

Thank you Peter.
robert99
 
Posts: 6
Joined: 28. January 2010 21:08


Return to XAMPP for Windows

Who is online

Users browsing this forum: DrSeussFreak and 66 guests