Xamp and Apache installation

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xamp and Apache installation

Postby adalberto » 07. February 2011 12:08

Hello guys,I am having problems with Apache,it is really strange.
I was using XAMPP for windows (Version 1.7.4) for a school work,no problems running XAMPP on my windows XP(Build 2600 SP3),my problems started when i needed to install APACHE HTTP server for windows(Version 2.2.17),my first though was "Well bye bye XAMPP" looking on a quick Internet search(Google) i find out that i just needed to press "delete" on my XAMPP folder to remove XAMPP,so far so good, the problems started when apache finish to install on windows,the service never start,it just pops out a windows with a error saying "system could not find the correct path" error 3.can someone help me out?
Thanks .
adalberto
 
Posts: 2
Joined: 07. February 2011 11:51

Re: Xamp and Apache installation

Postby Sharley » 07. February 2011 22:50

adalberto wrote:i find out that i just needed to press "delete" on my XAMPP folder to remove XAMPP,so far so good, the problems started when apache finish to install on windows,the service never start,it just pops out a windows with a error saying "system could not find the correct path" error 3
It is not enough just to delete the xampp folder to uninstall XAMPP.

You must also stop all XAMPP components and uninstall any Windows services then close the XAMPP Control Panel before deleting the xampp folder.

What you have left over is the Apache and MySQL Windows service entries in the registry and the Apache you just installed is trying to find that xampp folder.

So here is a possible fix:
Open a command prompt
Click start
Click on Run...
Type: cmd.exe
Click OK

Remove old or sticking services.
For Apache
Type:
sc delete apache2.2
Click OK

For MySQL
Type:
sc delete mysql
Click OK

Close the command console.

Now try and start your standalone server components.

You can alternatively search the registry and delete the apache and mysql entries manually if you are familiar with this process.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xamp and Apache installation

Postby adalberto » 08. February 2011 12:18

ok,I executed regedit,and deleted all the entries of,Mysql,apache,XAMPP ,that worked .

But i was hoping not to mess (Again) with my registry,i had enough problems fixing my registry,after messing up with it,but thanks sharley!

cheers for you all!
adalberto
 
Posts: 2
Joined: 07. February 2011 11:51


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests