phpMyAdmin cannot find file_listing.php

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpMyAdmin cannot find file_listing.php

Postby snickerzmom » 03. February 2011 19:52

I am a newbie to all this (the words you probably most dread reading) so I am going to error on the side of a thorough description of what I am running.

phpMyAdmin 3.2.4
MySQL Connector Net 5.2.5

I have built a Wordpress site on my local host and I am now trying to transfer it to the host server. When I open phpMyAdmin and select wordpress from the column on the left and export from the menu, I get the following error:

Fatal error: require_once() [function.require]: Failed opening required './libraries/file_listing.php' (include_path='.;\xampplite\php\PEAR') in C:\xampplite\phpMyAdmin\libraries\display_export.lib.php on line 22

I have searched my computer and not been able to locate a file called file_listing.php anywhere. Do I need to generate this file somehow? If so, how do I do it? Or is there something else that I might be missing? I am running this on a Windows 7 system, and I have stopped the IIS7 service which was interfering with this application.

Thank you in advance for your assistance & patience. I have been googling myself crazy for two days on this, without any success.
Posts: 2
Joined: 03. February 2011 19:49

Re: phpMyAdmin cannot find file_listing.php

Postby Sharley » 04. February 2011 00:31

I only have xampplite version 1.7.0 but the file_listing.php file is located in the xampplite\phpmyadmin\libraries folder - check this folder for that file.

It is also contained in the above folder in the full version of 1.7.3 so it is unlikely that xampplite 1.7.3 does not also contain this file in the above folder.

Make sure that IIS is not only turned off but that it is completely disabled.
Different name now - World Wide Publishing service.

See if this IIS Forum topic helps:
how to turn off iis 7

Good luck and best wishes.
User avatar
AF Moderator
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: phpMyAdmin cannot find file_listing.php

Postby snickerzmom » 04. February 2011 00:38

Thanks Sharley,

As it turned out, I did not have the file on my computer at all. Not sure what happened, but it simply didn't exist. I was lucky enough to find the php code for the file, so I recreated it, dropped it into the right folder and all is well now.

Thanks so much for your help.

And I will be checking out the article you referenced to turn off WWP completely.

Posts: 2
Joined: 03. February 2011 19:49

Return to XAMPP for Windows

Who is online

Users browsing this forum: jwhitley2002 and 43 guests