OpenSSL Support

Problems with the Windows version of XAMPP, questions, comments, and anything related.

OpenSSL Support

Postby jsavage » 02. February 2011 01:00

Could someone please confirm whether or not XAMPP 1.74 supports Openssl. If so, are there some instructions somewhere for getting it working. If not, is there a a version that has been compiled with this support turned on?

I have a number of test scripts already installed and whilst I can see from PHPinfo that OpenSSL is enabled, I am getting errors such as the following in my error log:

Code: Select all
openssl_csr_export() expects parameter 1 to be resource, boolean given in D:\\xampp\\htdocs\\openssl_demo.php on line 224
[Tue Feb 01 23:03:01 2011] [error] [client 127.0.0.1] PHP Warning:  openssl_csr_export_to_file() expects parameter 1 to be resource, boolean given in D:\\xampp\\htdocs\\openssl_demo.php on line 217


I also note that there are many versions of libeay32.dll in XAMPP. Which one should be on the windows path?

Finally, I have seen mention of a command /opt/lampp/lampp startssl for starting Lamp with ssl. Is there an equivalent for XAMPP?

Thanks all,

James
jsavage
 
Posts: 1
Joined: 02. February 2011 00:48

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests