ihstall of joomla fails

Problems with the Windows version of XAMPP, questions, comments, and anything related.

ihstall of joomla fails

Postby Dai777 » 30. January 2011 19:21

after upgrading to 1.7.4 I had to re-install joomla1.5 because the old one had loads of errors coming up now the install fails on the BD same as it does for linux. This vesion is Win7. So both Linux and Win7 fail on the DB when trying to do a fresh install of Joomla1.5

Here is the error:

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM CHARACTER SET `utf8`' at line 29 SQL=CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default '0', `type` varchar(30) NOT NULL default 'banner', `name` varchar(255) NOT NULL default '', `alias` varchar(255) NOT NULL default '', `imptotal` int(11) NOT NULL default '0', `impmade` int(11) NOT NULL default '0', `clicks` int(11) NOT NULL default '0', `imageurl` varchar(100) NOT NULL default '', `clickurl` varchar(200) NOT NULL default '', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default '0', `checked_out` tinyint(1) NOT NULL default '0', `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00', `editor` varchar(50) default NULL, `custombannercode` text, `catid` INTEGER UNSIGNED NOT NULL DEFAULT 0, `description` TEXT NOT NULL DEFAULT '', `sticky` TINYINT(1) UNSIGNED NOT NULL DEFAULT 0, `ordering` INTEGER NOT NULL DEFAULT 0, `publish_up` datetime NOT NULL default '0000-00-00 00:00:00', `publish_down` datetime NOT NULL default '0000-00-00 00:00:00', `tags` TEXT NOT NULL DEFAULT '', `params` TEXT NOT NULL DEFAULT '', PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`), INDEX `idx_banner_catid`(`catid`) ) TYPE=MyISAM CHARACTER SET `utf8`

I do find it strange how it worked in previous version and mowes portable but not in xamp1.7.4. Any help in resolving this would be most appreciated.

More or less getting the same error with mowes:
Access denied for user 'joomla15'@'localhost' to database 'joomla15' SQL=CREATE DATABASE `joomla15` CHARACTER SET `utf8`
Dai777
 
Posts: 12
Joined: 17. January 2011 16:37

Re: ihstall of joomla fails

Postby bnrbranding » 02. February 2011 02:12

I had the same problem. Here is how I fixed it -

1. Open the file JOOMLA\installation\sql\mysql\joomla.sql
2. Find TYPE=MyISAM
3. Replace with ENGINE=MyISAM
4. Save the file and try to install again

There are a bunch of instances, make sure you get them all. If possible do a search and replace.
bnrbranding
 
Posts: 1
Joined: 02. February 2011 02:09

Re: ihstall of joomla fails

Postby pkuenemann » 16. February 2011 13:16

Hi there,

I did as written, running Joomla 1.5.22 satble DE (German) on Win XP with XAmpp 1.4.7, replaced all 'TYPE=MyISAM' with 'ENGINE=MyISAM', started the installation anew and got another error:

'You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '# $Id: joomla.sql 100 2010-07-15 20:07:39Z sisko1990 $ CREATE TABLE `j' at line 1 SQL=# $Id: joomla.sql 100 2010-07-15 20:07:39Z sisko1990 $ CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL ...'

Any ideas? Would be grateful for any help,

Thanx,
Peter.
pkuenemann
 
Posts: 2
Joined: 16. February 2011 13:12

Re: ihstall of joomla fails

Postby pkuenemann » 16. February 2011 17:25

Using a higher version of Joomla would bring me into the trouble that the add-ons are not all available yet for Joomla 1.6x.
Well, I did not get Joomla 1.5.22 and XAmpp 1.7.4 running together so I installed XAmpp 1.7.3 which works fine now.

Thanx and bye,
Peter.
pkuenemann
 
Posts: 2
Joined: 16. February 2011 13:12

Re: install of joomla fails

Postby cdavis411 » 10. July 2011 22:31

I had the same issue when trying to install a premium template package with sample data. Just installing Joomla 1.5.23 was not the solution I was looking for because I needed (or wanted) the demo version of this template installed. This is what worked for me.

1) extract and upload the demo tplt/joomla package (in this case the Joomla version was 1.5.15)
2) extract the Full Stable Joomla 1.5.23 package
3) delete the following file from the Joomla 1.5.23 package installation/sql/mysql/sample_data.sql
4) upload the extracted Joomla 1.5.23 files (make sure to select overwrite all when prompted)
5) complete the Joomla install process
cdavis411
 
Posts: 1
Joined: 10. July 2011 22:23


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests